Shared vs. Switched Ethernet LANs

Courtesy of Dr. Emad Aboelela, the author of "Network Simulation Experiments Manual", full book can be found at [1]

Prepared by: Dr. K. Salah
Shared Ethernet LANs
A Direct Link Network with Media Access Control

Objective

This lab is designed to demonstrate the operation of the Ethernet network. The simulation in this lab will help you examine the performance of the Ethernet network under different scenarios.

Overview

The Ethernet is a working example of the more general Carrier Sense, Multiple Access with Collision Detect (CSMA/CD) local area network technology. The Ethernet is a multiple-access network, meaning that a set of nodes sends and receives frames over a shared link. The "carrier sense" in CSMA/CD means that all the nodes can distinguish between an idle and a busy link. The "collision detect" means that a node listens as it transmits and can therefore detect when a frame it is transmitting has interfered (collided) with a frame transmitted by another node. The Ethernet is said to be a 1-persistent protocol because an adaptor with a frame to send transmits with probability 1 whenever a busy line goes idle.

In this lab you will set up an Ethernet with 14 nodes connected via a coaxial link in a bus topology. The coaxial link is operating at a data rate of 10 Mbps. You will study how the throughput of the network is affected by the network load as well as the size of the packets.

Procedure

Create a New Project

To create a new project for the Ethernet network:

1. Start OPNET IT Modeler Choose New from the File menu.
2. Select Project Click OK Name the project <your initials>_Ethernet, and the scenario Coax Click OK.
3. In the Startup Wizard: Initial Topology dialog box, make sure that Create Empty Scenario is selected Click Next Choose Office from the Network Scale list Click Next Assign 200 to X Span and keep Y Span as 100 Click Next twice Click OK.
   Local area networks (LANs) are designed to span distances of up to a few thousand meters.
4. Close the Object Palette dialog box.
Create the Network

To create our coaxial Ethernet network:

1. To create the network configuration, select **Topology** ➔ **Rapid Configuration**. From the drop-down menu choose **Bus** and click **OK**.

2. Click the **Select Models** button in the **Rapid Configuration** dialog box. From the **Model List** drop-down menu choose **ethcoax** and click **OK**.

3. In the **Rapid Configuration** dialog box, set the following eight values and click **OK**.

   - **eth_tap** is an Ethernet bus tap that connects a node with the bus.
   - **eth_coax** is an Ethernet bus that can connect nodes with bus receivers and transmitters via taps.

4. To configure the coaxial bus, right-click on the horizontal link ➔ **Select Advanced Edit Attributes** from the menu:

   a. Click on the value of the **model** attribute ➔ **Select Edit** from the drop-down menu ➔ Choose the **eth_coax_adv** model.
   
   b. Assign the value **0.05** to the **delay** attribute (propagation delay in sec/m).
   
   c. Assign **5** to the **thickness** attribute.
   
   d. Click **OK**.
A higher delay is used here as an alternative to generating higher traffic which would require much longer simulation time. Thickness specifies the thickness of the line used to "draw" the bus link.

5. Now you have created the network. It should look like the illustration below.

6. Make sure to save your project.

Configure the Network Nodes

To configure the traffic generated by the nodes:

1. Right-click on any of the 30 nodes ➔ Select Similar Nodes. Now all nodes in the network are selected.
2. Right-click on any of the 30 nodes ➔ Edit Attributes.
3. Check the Apply Changes to Selected Objects check box. This is important to avoid reconfiguring each node individually.
4. Expand the Traffic Generation Parameters hierarchy:
A. Change the value of the **ON State Time** to `exponential(100)`.

B. Change the value of the **OFF State Time** to `exponential(0)`.

(Note: Packets are generated only in the "ON" state.)

5. Expand the **Packet Generation Arguments** hierarchy:

A. Change the value of the **Packet Size** attribute to `constant(1024)`.

B. Right-click on the **Interarrival Time** attribute and choose **Promote Attribute to Higher Level**. This allows us to assign multiple values to the **Interarrival Time** attribute and hence to test the network performance under different loads.

The argument of the exponential distribution is the mean of the interval between successive events. In the exponential distribution the probability of occurrence of the next event by a given time is not at all dependent upon the time of occurrence of the last event or the elapsed time since that event. The interarrival time is the time between successive packet generations in the "ON" state.

6. Click **OK** to return back to the **Project Editor**.

7. Make sure to save your project.
Configure the Simulation

To examine the network performance under different loads, you need to run the simulation several times by changing the load into the network. There is an easy way to do that. Recall that we promoted the Interarrival Time attribute for package generation. Here we will assign different values to that attribute:

1. Click on the **Configure/Run Simulation** button:
2. Make sure that the **Common** tab is chosen ⇒ Assign 15 seconds to the **Duration**.
3. Click on the **Object Attributes** tab.
4. Click on the **Add** button. The **Add Attribute** dialog box should appear filled with the promoted attributes of all nodes in the network (if you do not see the attributes in the list, close the whole project and reopen it). You need to add the Interarrival Time attribute for all nodes. To do that:
   A. Click on the first attribute in the list (**Office Network.node_0.Traffic Generation …**) ⇒ Click the **Wildcard** button ⇒ Click on **node_0** and choose the asterisk (*) from the drop-down menu ⇒ Click **OK**.
   B. A new attribute is now generated containing the asterisk (the second one in the list), and you need to add it by clicking on the corresponding cell under the **Add ?** column.
   C. The **Add Attribute** dialog box should look like the following. Click **OK**.
5. Now you should see the Office Network.*.Traffic Generation Parameter ... in the list of simulation object attributes. Click on that attribute to select it and click the Values button of the dialog box.

6. Add the following nine values. (Note: To add the first value, double-click on the first cell in the Value column and type "exponential (2)" into the textbox and hit enter. Repeat this for all nine values.)

7. Click OK. Now look at the upper-right corner of the Simulation Configuration dialog box and make sure that the Number of runs in set is 9.

8. For each simulation of the nine runs, we need the simulator to save a "scalar" value that represents the "average" load in the network and to save another scalar value that represents the average throughput of the network. To save these scalars we need to configure the simulator to save them in a file. Click on the Advanced tab in the Configure Simulation dialog box.
9. Assign `<your initials> Ethernet_Coax` to the Scalar file text field.

10. Click OK and then save your project.

Choose the Statistics

To choose the statistics to be collected during the simulation:

1. Right-click anywhere in the project workspace (but not on one of the nodes or links) and select *Choose Individual Statistics* from the pop-up menu ➔ Expand the *Global Statistics* hierarchy.
   A. Expand the *Traffic Sink* hierarchy ➔ Click the check box next to *Traffic Received (packets/sec)* (make sure you select the statistic with units of packets/sec),
   B. Expand the *Traffic Source* hierarchy ➔ Click the check box next to *Traffic Sent (packets/sec)*.
   C. Click OK.

2. Now to collect the average of the above statistics as a scalar value by the end of each simulation run:
   A. Select *Choose Statistics (Advanced)* from the *Simulation* menu.
   B. The *Traffic Sent* and *Traffic Received* probes should appear under the *Global Statistic Probes*.
   C. Right-click on *Traffic Received* probe ➔ *Edit Attributes*. Set the *scalar data* attribute to *enabled* ➔ Set the *scalar type* attribute to *time average* ➔ Compare to the following figure and click OK.
   D. Repeat the previous step with the *Traffic Sent* probe.
   E. Select save from the *File* menu in the *Probe Model* window and then close that window.
F. Now you are back to the Project Editor. Make sure to save your project.

![Attribute Table]

A probe represents a request by the user to collect a particular piece of data about a simulation.

**Run the Simulation**

To run the simulation:

1. Click on the **Configure/Run Simulation** button: Make sure that 15 second(s) (not hours) is assigned to the **Duration** Click **Run**. Depending on the speed of your processor, this may take several minutes to complete.

2. Now the simulator is completing nine runs, one for each traffic generation interarrival time (representing the load into the network). Notice that each successive run takes longer to complete because the traffic intensity is increasing.

3. After the nine simulation runs complete, click **Close**.

4. Save your project.

When you rerun the simulation, OPNET IT Modeler will "append" the new results to the results already in the scalar file. To avoid that, delete the scalar file before you start a new run. (Note: Deleting the scalar file after a run will result in losing the collected results from that run.)

Go to the **File** menu ➔ Select **Model Files** ➔ Delete Model Files ➔ Select ( .os): **Output Scalars** Select the scalar file to be deleted; in this lab it is `<your initials>_Ethernet_Coax_Scalar` Confirm the deletion by clicking **OK** ➔ Click **Close**.
**View the Results**

To view and analyze the results:

1. Select **View Results (Advanced)** from the **Results** menu. Now the **Analysis Configuration** tool is open.

2. Recall that we saved the average results in a scalar file. To load this file, select **Load Output Scalar File** from the **File** menu. Select `<your initials>_Ethernet_Coax` from the pop-up menu.

3. Select **Create Scalar Panel** from the **Panels** menu. Assign **Traffic Source.Traffic Sent (packets/sec).average** to **Horizontal** and **Traffic Sink.Traffic Received (packets/sec).average** to **Vertical**. Click **OK**.

4. The resulting graph should resemble the one below:
Switched LANs
A Set of Local Area Networks Interconnected by Switches

Objective

This lab is designed to demonstrate the implementation of switched local area networks. The simulation in this lab will help you examine the performance of different implementations of local area networks connected by switches and hubs.

Overview

There is a limit to how many hosts can be attached to a single network and to the size of a geographic area that a single network can serve. Computer networks use switches to enable the communication between one host and another, even when no direct connection exists between those hosts. A switch is a device with several inputs and outputs leading to and from the hosts that the switch interconnects. The core job of a switch is to take packets that arrive on an input and forward (or switch) them to the right output so that they will reach their appropriate destination.

A key problem that a switch must deal with is the finite bandwidth of its outputs. If packets destined for a certain output arrive at a switch and their arrival rate exceeds the capacity of that output, then we have a problem of contention. In this case, the switch will queue, or buffer, packets until the contention subsides. If it lasts too long, however, the switch will run out of buffer space and be forced to discard packets. When packets are discarded too frequently, the switch is said to be congested.

In this lab you will set up switched LANs using two different switching devices: hubs and switches. A hub forwards the packet that arrives on any of its inputs on all the outputs regardless of the destination of the packet. On the other hand, a switch forwards incoming packets to one or more outputs depending on the destination(s) of the packets. You will study how the throughput and collision of packets in a switched network are affected by the configuration of the network and the types of switching devices that are used.

Procedure

Create a New Project

To create a new project for the Ethernet network:

1. Start OPNET IT Modeler \(\Rightarrow\) Choose New from the File menu.
2. Select Project \(\Rightarrow\) Click OK \(\Rightarrow\) Name the project <your initials>_SwitchedLAN, and the scenario OnlyHub \(\Rightarrow\) Click OK.
3. In the Startup Wizard: Initial Topology dialog box, make sure that Create Empty Scenario is selected → Click Next → Choose Office from the Network Scale list → Click Next three times → Click OK.

4. Close the Object Palette dialog box.

Create the Network

To create our switched LAN:

1. To create the network configuration, select Topology ⇒ Rapid Configuration. From the drop-down menu choose Star and click OK.

2. Click the Select Models button in the Rapid Configuration dialog box. From the Model List drop-down menu choose ethernet and click OK.

3. In the Rapid Configuration dialog box, set the following five values Center Node Model = ethernet16_hub, Periphery Node Model = ethernet_station, Link Model = 10BaseT, Number=16, Y=50, and Radius = 42 and click OK.

The prefix ethernet16_ indicates that the device supports up to 16 Ethernet connections.

The 10BaseT link represents an Ethernet connection operating at 10 Mbps.

1. Right-click on node_16, which is the hub ⇒ Edit Attributes ⇒ Change the name attribute to Hub1 and click OK.

2. Now that you have created the network, it should look like the following one.
3. Make sure to save your project.

Configure the Network Nodes

Here you will configure the traffic generated by the stations.

1. Right-click on any of the 16 stations (node_0 to node_15) ➞ Select Similar Nodes. Now all stations in the network are selected.
2. Right-click on any of the 16 stations ➞ Edit Attributes.
   A. Check the Apply Changes to Selected Objects check box. This is important to avoid reconfiguring each node individually.
3. Expand the hierarchies of the Traffic Generation Parameters attribute and the Packet Generation Arguments attribute ➞ Set the following four values:

![Attribute Editing Window]

4. Click OK to close the attribute editing window(s). Save your project.

Choose Statistics

To choose the statistics to be collected during the simulation:

1. Right-click anywhere in the project workspace and select Choose Individual Statistics from the pop-up menu.
2. In the Choose Results dialog box, choose the following four statistics:

The **Ethernet Delay** represents the end to end delay of all packets received by all the stations.

**Traffic Received** (in packets/sec) by the traffic sinks across all nodes.

**Traffic Sent** (in packets/sec) by the traffic sources across all nodes.

**Collision Count** is the total number of collisions encountered by the hub during packet transmissions.

3. Click **OK**.

**Configure the Simulation**

Here we need to configure the duration of the simulation:

1. Click on the **Configure/Run Simulation** button:
2. Set the duration to be **2.0** minutes.
3. Click **OK**

**Duplicate the Scenario**

The network we just created utilizes only one hub to connect the 16 stations. We need to create another network that utilizes a switch and see how this will affect the performance of the network. To do that we will create a duplicate of the current network:

1. Select **Duplicate Scenario** from the **Scenarios** menu and give it the name **HubAndSwitch**. Click **OK**.
2. Open the **Object Palette** by clicking on . Make sure that **Ethernet** is selected in the pull-down menu on the object palette.
3. We need to place a hub and a switch in the new scenario. (They are circled in the following figure.)

![Object Palette](image)

4. To add the **Hub**, click its icon in the object palette ➔ Move your mouse to the workspace ➔ Click to drop the hub at a location you select. Right-click to indicate you are done deploying hub objects.

5. Similarly, add the **Switch**.

6. Close the **Object Palette**.

7. Right-click on the new hub ➔ **Edit Attributes** ➔ Change the **name** attribute to **Hub2** and click **OK**.

8. Right-click on the switch ➔ **Edit Attributes** ➔ Change the **name** attribute to **Switch** and click **OK**.

9. Reconfigure the network of the **HubAndSwitch** scenario so that it looks like the following one. **Hints:**

10. To remove a link, select it and choose **Cut** from the **Edit** menu (or simply hit the Delete key). You can select multiple links and delete all of them at once.

11. To add a new link, use the **10BaseT** link available in the **Object Palette**.

![Network Diagram](image)

12. Save your project.
Run the Simulation

To run the simulation for both scenarios simultaneously:

1. Select **Manage Scenarios** from the **Scenarios** menu.
2. Change the values under the **Results** column to `<collect>` (or `<recollect>`) for both scenarios. Compare to the following figure.

![Manage Scenarios](image)

3. Click **OK** to run the two simulations. Depending on the speed of your processor, this may take several minutes to complete.
4. After the two simulation runs complete, one for each scenario, click **Close**.
5. Save your project.

View the Results

To view and analyze the results:

1. Select **Compare Results** from the **Results** menu.
2. Change the drop-down menu in the lower-right part of the **Compare Results** dialog box from **As Is** to **time_average**, as shown. **time_average** is the average value over time of the values generated during the collection window. This average is performed assuming a "sample-and-hold" behavior of the data set (i.e., each value is weighted by the amount of time separating it from the following update and the sum of all the weighted values is divided by the width of the collection window). For example, suppose you have a 1-second bucket in which 10 values have been generated. The first 7 values were generated between 0 and 0.3 seconds, the 8th value at 0.4 seconds, the 9th value at 0.6 seconds, and the 10th at 0.99 seconds. Because the last 3 values have higher durations, they are weighted more heavily in calculating the time average.
3. Select the **Traffic Sent (packets/sec)** statistic and click **Show**. The resulting graph should resemble the one below. As you can see, the traffic sent in both scenarios is almost identical.

4. Select the **Traffic Received (packets/sec)** statistic and click **Show**. The resulting graph should resemble the one below. As you see, the traffic received with the second scenario, **HubAndSwitch**, is higher than that of the **OnlyHub**.
5. Select the **Delay (sec)** statistic and click **Show**. The resulting graph should resemble the one below. (Note: Result may vary slightly due to different node placement.)

6. Select the **Collision Count** statistic for **Hub1** and click **Show**.

7. On the resulting graph right-click anywhere on the graph area ➔ Choose **Add Statistic** ➔ Expand the hierarchies as shown below ➔ Select the **Collision**
Count statistic for Hub2 ➔ Change As Is to time_average ➔ Click Add.

8. The resulting graph should resemble the one below.

9. Save your project.
Further Readings

OPNET Building Networks: From the **Protocols** menu, select Methodologies ➔ Building Network Topologies.

Questions

1. Explain why adding a switch makes the network perform better in terms of throughput and delay.
2. We analyzed the collision counts of the hubs. Can you analyze the collision count of the "Switch"? Explain your answer.
3. Create two new scenarios. The first one is the same as the **OnlyHub** scenario but replace the hub with a switch. The second new scenario is the same as the **HubAndSwitch** scenario but replace both hubs with two switches, remove the old switch, and connect the two switches you just added together with a 10BaseT link. Compare the performance of the four scenarios in terms of delay, throughput, and collision count. Analyze the results. Note: To replace a hub with a switch, right-click on the hub and assign ethernet16_switch to its model attribute.

Lab Report

Prepare a report that include the answers to the above questions as well as the graphs you generated from the simulation scenarios. Discuss the results you obtained and compare these results with your expectations. Mention any anomalies or unexplained behaviors.