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• Simulate systems described using 
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EXPERIMENT # 1: INTRODUCTION TO LABVIEW 
 
 
OBJECTIVE: 
 
The objective of this experiment is the introduction of LabView. 

INTRODUCTION: 

LabVIEW (short for Laboratory Virtual Instrumentation Engineering Workbench) is 
a platform and development environment for a visual programming language from 
National Instruments. The graphical language is named "G". LabVIEW is commonly 
used for data acquisition, instrument control, and industrial automation on a variety of 
platforms including Microsoft Windows, various flavors of UNIX, Linux, and Mac OS.  

One benefit of LabVIEW over other development environments is the extensive support 
for accessing instrumentation hardware. Drivers and abstraction layers for many different 
types of instruments and buses are included or are available for inclusion. These present 
themselves as graphical nodes. The abstraction layers offer standard software interfaces 
to communicate with hardware devices. The provided driver interfaces save program 
development time. Many libraries with a large number of functions for data acquisition, 
signal generation, mathematics, statistics, signal conditioning, analysis, etc., along with 
numerous graphical interface elements are provided in several LabVIEW package 
options. Another benefit of the LabVIEW environment is the platform independent nature 
of the G-code (LabVIEW programming language), which is (with the exception of a few 
platform-specific functions) portable between the different LabVIEW systems for 
different operating systems (Windows, MacOSX and Linux).  

DATAFLOW: 

The programming language used in LabVIEW, called "G", is a dataflow language. 
Execution is determined by the structure of a graphical block diagram (the LV-source 
code) on which the programmer connects different function-nodes by drawing wires. 
These wires propagate variables and any node can execute as soon as all its input data 
become available. Since this might be the case for multiple nodes simultaneously, G is 
inherently capable of parallel execution.  
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The afore-mentioned data-flow (which can be "forced", typically by linking inputs and 
outputs of nodes) completely defines the execution sequence, and that can be fully 
controlled by the programmer. Thus, the execution sequence of the LabVIEW graphical 
syntax is as well-defined as with any textually coded language such as C, Visual BASIC, 
etc. Furthermore, LabVIEW does not require type definition of the variables; the wire 
type is defined by the data-supplying node. LabVIEW supports polymorphism in that 
wires automatically adjust to various types of data. 



 
 
Screenshot of a simple LabVIEW program that generates, synthesizes, analyzes and 
displays waveforms, showing the block diagram and front panel. Each symbol on the 
block diagram represents a LabVIEW subroutine (subVI) which can be another 
LabVIEW program or a LV library function. 
 

GRAPHICAL PROGRAMMING: 
LabVIEW ties the creation of user interfaces (called front panels) into the development 
cycle. LabVIEW programs/subroutines are called virtual instruments (VIs). Each VI has 
three components: Each VI contains three main parts: 
 

1. Front Panel - How the user interacts with the VI. 
2. Block Diagram - The code that controls the program. 
3. Icon/Connector - Means of connecting a VI to other VIs. 

 
The Front Panel is the user interface of the VI, to interact with the user when the 
program is running. Users can control the program, change inputs, and see data updated 
in real time. You build the front panel with controls and indicators (available on the 
Control Palette), which are the interactive input and output terminals of the VI, 
respectively. Controls are knobs, pushbuttons, dials, and other input devices. Indicators 
are graphs, LEDs, and other displays.  
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Controls simulate instrument input devices and supply values to the block diagram of the 
VI. Indicators simulate instrument output devices and display values the block diagram 
acquires or generates. These may include data, program states, and other information. 
Every front panel control or indicator has a corresponding terminal on the block diagram. 
When a VI is run, values from controls flow through the block diagram, where they are 

http://en.wikipedia.org/wiki/Image:LabVIEWCode.png�


used in the functions on the diagram, and the results are passed into other functions or 
indicators. 
 
 

 
The Controls palette is 
available only on the front 
panel. Go to Window»Show 
Controls Palette 
 or right-click the front panel 
workspace to display the 
Controls 
palette. 
 
 

 
The Block Diagram contains this graphical source code. Front panel objects appear 
as terminals on the block diagram. Additionally, the block diagram contains 
functions and structures from built-in LabVIEW VI libraries. These can be accessed from 
the Functions Palette. Wires connect each of the nodes on the block diagram, including 
control and indicator terminals, functions, and structures. 

 

The Functions palette is 
available only on the block 
diagram. Select 
Window»Show Functions 
Palette or right-click the block 
diagram workspace to display 
the Functions palette 

 

The Icon/Connector may represent the VI as a subVI in block diagrams of calling VIs. 
Controls and indicators on the front panel allow an operator to input data into or extract 
data from a running virtual instrument. However, the front panel can also serve as a 
programmatic interface. Thus a virtual instrument can either be run as a program, with 
the front panel serving as a user interface, or, when dropped as a node onto the block 
diagram, the front panel defines the inputs and outputs for the given node through the 
connector pane. This implies each VI can be easily tested before being embedded as a 
subroutine into a larger program. 

The graphical approach also allows non-programmers to build programs by simply 
dragging and dropping virtual representations of the lab equipment with which they are 
already familiar. The LabVIEW programming environment, with the included examples 
and the documentation, makes it easy to create small applications. For complex 
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algorithms or large-scale code it is important that the programmer possess an extensive 
knowledge of the special LabVIEW syntax and the topology of its memory management. 
The most advanced LabVIEW development systems offer the possibility of building 
stand-alone applications.  

Other features that you will need include the Tools Palette which is a Floating Palette 
that is used to operate and modify front panel and block diagram objects and the Status 
Toolbar. They contain the following tools and buttons, respectively: 
 
Tools Palette: 
 
            
   
 
 
 
 
 
 
 
 
 
 
 
 
Status Bar: 
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EXPERIMENT # 2: BUILDING A VI 
 
 
OBJECTIVE: 
 
The objective of this experiment is to build a VI. 
 
INTRODUCTION: 
 
Before building our own VI we will first examine the Signal Generation and 
Processing VI and run it. Change the frequencies and types of the input signals and 
notice how the display on the graph changes. Change the Signal Processing Window and 
Filter options. After you have examined the VI and the different options you can change, 
stop the VI by pressing the Stop button. 
 
1. Select Start»Programs»National Instruments»LabVIEW 8.0 » LabVIEW to 
launch LabVIEW. The LabVIEW dialog box appears. 

 
2. Select Help»Find Examples. The dialog box that appears lists and links to all 
available LabVIEW example VIs. 

 
3. On the Browse Tab, select browse according to task. Choose Analyzing and 
Processing Signals, then Signal Processing, then Signal Generation and Processing.vi. 

This will open the Signal Generation and Processing VI Front Panel. 
 
Note You also can open the VI by clicking the Open VI button and navigating to 
labview\examples\apps\demos.llb\Signal Generation and Processing.vi. 
 
FRONT PANEL 
 
 4. Click the Run button on the toolbar, shown at left, to run this VI. 

This VI determines the result of filtering and windowing a generated signal. This 
example also displays the power spectrum for the generated signal. The resulting 
signals are displayed in the graphs on the front panel, as shown in the following 
figure. 
 
 
5. Use the Operating tool, shown at left, to change the Input Signal and the Signal 
Processing, use the increment or decrement arrows on the control, and drag the 
pointer to the desired Frequency. 
6. Press the More Info… button or [F5] to read more about the analysis functions. 
 
7. Press the Stop button or [F4] to stop the VI. 

 
 



 
BLOCK DIAGRAM 
 
8. Select Window»Show Diagram or press the <Ctrl-E> keys to display 
    the block diagram for the Signal Generation and Processing VI. 

 
    This block diagram contains several of the basic block diagram elements, including     
    subVIs, functions, and structures, which you will learn about later in this course. 

 
9. Select Window»Show Panel or press the <Ctrl-E> keys to return to the Front     
    Panel. 

 
10. Close the VI and do not save changes. 

 
CREATING YOUR OWN VI 
 
When you create an object on the Front Panel, a terminal will be created on the 
Block Diagram. These terminals give you access to the Front Panel objects from the 
Block Diagram code. Each terminal contains useful information about the Front Panel 
object it corresponds to. For example, the color and symbols provide the data type. 
Double-precision, floating point numbers are represented with orange terminals and the 
letters DBL, boolean terminals are green with TF lettering. In general, orange terminals 
should wire to orange terminals, green to green, and so on. This is not a hard-and-fast 
rule; LabVIEW will allow a user to connect a blue terminal (integer value) to an orange 
terminal (fractional value), for example.  
 
For more help with the terminals, right-click on the function and select Visible 
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Items»Terminals. The functions picture will be pulled back to reveal the connection 



terminals. For additional help, select Help»Show Context Help, or press <Ctrl-H>. As 
you move your mouse over the function, this window will show you the function, 
terminals, and a brief help description in the context help window. For organization you 
can, right-click on the particular wire in question and choose Clean Up Wire to 
automatically re-route that wire. 
 
 
 
 
 
VI # 1- Convert °C to °F 
 
Complete the following steps to create a VI that takes a number representing degrees 
Celsius and converts it to a number representing degrees Fahrenheit. 
 
In wiring illustrations, the arrow at the end of this mouse icon shows where to click and 
the number on the arrow indicates how many times to click. 
 
Front Panel 
 

1. Select File»New to open a new front panel. 
2. (Optional) Select Window»Tile Left and Right to display the front panel and 

block diagram side by side. 
3. Create a numeric digital control. You will use this control to enter the value 

for degrees Centigrade. 
a. Select the digital control on the Controls»Numeric Controls palette. 

If the Controls palette is not visible, right-click an open area on the 
front panel to display it. 

b. Move the control to the front panel and click to place the control. 
c. Type deg C inside the label and click outside the label or click the 

Enter button on the toolbar. If you do not type the name immediately, 
LabVIEW uses a default label. You can edit a label at any time by 
using the Labeling tool. 

4. Create a numeric digital indicator. You will use this indicator to display the 
value for degrees Fahrenheit. 

a. Select the digital indicator on the Controls»Numeric Indicators 
palette. 

b. Move the indicator to the front panel and click to place the indicator. 
c. Type deg F inside the label and click outside the label or click the 

Enter button. 
 
LabVIEW creates corresponding control and indicator terminals on the block diagram. 
The terminals represent the data type of the control or indicator. For example, a DBL 
terminal represents a double-precision, floating-point numeric control or indicator. 
 
Note Control terminals have a thicker border than indicator terminals. 
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Block Diagram 

5. Display the block diagram by clicking it or by selecting Window»Show 
Diagram. 

 

 
 
Note:  Block Diagram terminals can be viewed as icons or as terminals.  To change the 
way LabVIEW displays these objects right click on a terminal and select View As Icon.   
 

 
 

6. Select the Multiply and Add functions on the Functions»Numeric palette and 
place them on the block diagram. If the Functions palette is not visible, right-
click an open area on the block diagram to display it. 

7. Select the numeric constant on the Functions»Numeric palette and place two 
of them on the block diagram. When you first place the numeric constant, it is 
highlighted so you can type a value. 

8. Type 1.8 in one constant and 32.0 in the other. If you moved the constants 
before you typed a value, use the Labeling tool to enter the values. 

9. Use the Wiring tool to wire the icons as shown in the previous block diagram. 
• To wire from one terminal to another, use the Wiring tool to click the 

first terminal, move the tool to the second terminal, and click the 
second terminal, as shown in the following illustration. You can start 
wiring at either terminal. 
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• You can bend a wire by clicking to tack the wire down and moving the 
cursor in a perpendicular direction. Press the spacebar to toggle the 
wire direction. 

• To identify terminals on the nodes, right-click the Multiply and Add 
functions and select Visible Items»Terminals from the shortcut menu 
to display the connector pane. Return to the icons after wiring by right-
clicking the functions and selecting Visible Items» 

• Terminals from the shortcut menu to remove the checkmark. 
• When you move the Wiring tool over a terminal, the terminal area 

blinks, indicating that clicking will connect the wire to that terminal 
and a tip strip appears, listing the name of the terminal. 

• To cancel a wire you started, press the <Esc> key, right-click, or click 
the source terminal. 

10. Display the front panel by clicking it or by selecting Window»Show Panel. 
11. Save the VI for later use (have a folder by your own name). 
12. Enter a number in the digital control and run the VI. 

a. Use the Operating tool or the Labeling tool to double-click the digital 
control and type a new number. 

b. Click the Run button to run the VI. 
c. Try several different numbers and run the VI again. 

 
VI # 2 – Create a SubVI 
 
Front Panel 

1. Select File»Open and navigate to your folder to open the C to F VI. 
The following front panel appears. 

 
 
 
 
 
 
 
 
2. Right-click the icon in the upper right corner of the front panel and select Edit 

Icon from the shortcut menu. The Icon Editor dialog box appears. 
3. Double-click the Select tool on the left side of the Icon Editor dialog box to 

select the default icon. 
4. Press the <Delete> key to remove the default icon. 
5. Double-click the Rectangle tool to redraw the border. 
6. Create the following icon. 
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a. Use the Text tool to click the editing area. 
b. Type C and F. 
c. Double-click the Text tool and change the font to Small Fonts. 
d. Use the Pencil tool to create the arrow. (To draw horizontal or vertical 

straight lines, press the <Shift> key while you use the Pencil tool to 
drag the cursor). 

e. Use the Select tool and the arrow keys to move the text and arrow you 
created. 

f. Select the B&W icon and select 256 Colors in the Copy from field to 
create a black and white icon, which LabVIEW uses for printing 
unless you have a color printer. 

g. When the icon is complete, click the OK button to close the Icon 
Editor dialog box. The icon appears in the upper right corner of the 
front panel and block diagram. 

7. Right-click the icon on the front panel and select Show Connector from the 
shortcut menu to define the connector pane terminal pattern. 
LabVIEW selects a connector pane pattern based on the number of controls 
and indicators on the front panel. For example, this front panel has two 
terminals, deg C and deg F, so LabVIEW selects a connector pane pattern 
with two terminals. 

8. Assign the terminals to the digital control and digital indicator. 
a. Select Help»Show Context Help to display the Context Help 

window. View each connection in the Context Help window as you 
make it. 

b. Click the left terminal in the connector pane. The tool automatically 
changes to the Wiring tool, and the terminal turns black. 

c. Click the deg C control. The left terminal turns orange, and a marquee 
highlights the control. 
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d. Click an open area of the front panel. The marquee disappears, and the 
terminal changes to the data type color of the control to indicate that 
you connected the terminal. 



e. Click the right terminal in the connector pane and click the deg F 
indicator. The right terminal turns orange. 

f. Click an open area on the front panel. Both terminals are orange. 
g. Move the cursor over the connector pane. The Context Help window 

shows that both terminals are connected to floating-point values. 
9. Select File»Save to save the VI. 

 
 
VI # 3 – Using Loops 
Use a while loop and a waveform chart to build a VI that demonstrates software timing.  
 
Front Panel 

1. Open a new VI. 
2. Build the following front panel. 
 

 
 

a. Select the horizontal pointer slide on the Controls»Numeric Controls 
palette and place it on the front panel. You will use the slide to change the 
software timing. 

b. Type millisecond delay inside the label and click outside the label 
or click the Enter button on the toolbar, shown at left. 

c. Place a Stop Button from the Controls»Buttons palette. 
d. Select a waveform chart on the Controls»Graph Indicators palette and 

place it on the front panel. The waveform chart will display the data in real 
time. 

e. Type Value History inside the label and click outside the label or 
click the Enter button. 

f. The waveform chart legend labels the plot Plot 0. Use the Labeling tool 
to triple-click Plot 0 in the chart legend, type Value, and click outside 
the label or click the Enter button to relabel the legend. 
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g. The random number generator generates numbers between 0 and 1, in a 
classroom setting you could replace this with a data acquisition VI. Use 
the Labeling tool to double-click 10.0 in the y-axis, type 1, and click 
outside the label or click the Enter button to rescale the chart. 



h. Change –10.0 in the y-axis to 0. 
i. Label the y-axis Value and the x-axis Time (sec). 

 
 
Block Diagram 
 

3. Select Window»Show Diagram to display the block diagram. 
 
4. Enclose the two terminals in a While Loop, as shown in the following block 

diagram. 

 
a. Select the While Loop on the Functions»Execution Control palette. 
b. Click and drag a selection rectangle around the two terminals. 
c. Use the Positioning tool to resize the loop, if necessary. 
 

5. Select the Random Number (0-1) on the Functions»Arithmetic and 
Comparison»Numeric palette. Alternatively you could use a VI that is 
gathering data from an external sensor. 

6. Wire the block diagram objects as shown in the previous block diagram. 
7. Save the VI as Use a Loop.vi in your folder  
8. Display the front panel by clicking it or by selecting Window»Show Panel. 
9. Run the VI. The section of the block diagram within the While Loop border 

executes until the specified condition is TRUE. For example, while the STOP 
button is not pressed, the VI returns a new number and displays it on the 
waveform chart. 

10. Click the STOP button to stop the acquisition. The condition is FALSE, and 
the loop stops executing. 

11. Format and customize the X and Y scales of the waveform chart. 
a. Right-click the chart and select Properties from the shortcut menu. 

The following dialog box appears. 
b. Click the Scale tab and select different styles for the y-axis. You also 

can select different mapping modes, grid options, scaling factors, and 
formats and precisions.  Notice that these will update interactively on 
the waveform chart 
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c. Select the options you desire and click the OK button. 



 

 
 

12. Right-click the waveform chart and select Data Operations»Clear Chart 
from the shortcut menu to clear the display buffer and reset the waveform 
chart. If the VI is running, you can select Clear Chart from the shortcut 
menu. 

 
Adding Timing 
When this VI runs, the While Loop executes as quickly as possible. Complete the 
following steps to take data at certain intervals, such as once every half-second, as shown 
in the following block diagram.  
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a. Place the Time Delay Express VI located on the Functions»Execution 
Control palette. In the dialog box that appears, insert 0.5.  This 
function would make sure that each iteration occurs every half-second 
(500 ms). 



b. Divide the millisecond delay by 1000 to get time in seconds.  Connect 
the output of the divide function to the Delay Time (s) input of the 
Time Delay Express VI.  This will allow you to adjust the speed of the 
execution from the pointer slide on the front panel. 

13. Save the VI, because you will use this VI later in the course. 
14. Run the VI. 
15. Try different values for the millisecond delay and run the VI again.  Notice 

how this effects the speed of the number generation and display.  
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EXPERIMENT # 3: EXERCISES IN LABVIEW 
 
 
OBJECTIVE: 
 
The objective of this experiment is to gain familiarity with the various functions of 
LabView. 
 
INTRODUCTION: 
 
We will conduct the following exercises to gain familiarity with the various functions of 
LabVIEW. We will need them to develop more advanced VIs in the future. 
 
VI # 4 - ANALYZING AND LOGGING DATA 
 
Complete the following steps to build a VI that measures temperature every 0.25 s for 
10s. During the acquisition, the VI displays the measurements in real time on a waveform 
chart. After the acquisition is complete, the VI plots the data on a graph and calculates the 
minimum, maximum, and average temperatures. The VI displays the best fit of the 
temperature graph. 
 
Front Panel 

1. Open a new VI and build the following front panel using the following tips. 

 
 

• Do not create the Mean, Max, and Min indicators yet.  Create 
them on the Block Diagram by right clicking on the functions and 
choosing Create Indicator.  Then position them on the Front Panel. 

 



Block Diagram 
 

2. Build the following block diagram. 

 
 

a. Select Functions»All Functions»Select a VI… and choose 
Thermometer.vi (from previous exercise).   

b. Place the Wait Until Next ms Multiple function located on the 
Functions»All Functions »Time & Dialog palette and create a 
constant of 250. Much like the Time Delay Express VI, this function 
causes the For Loop to execute every 0.25 s (250 ms).   

c. Place the Array Max & Min function located on the Functions»All 
Functions »Array palette. This function returns the maximum and 
minimum temperature. 

d. Place the Mean VI located on the Functions»All Functions» 
Mathematics»Probability and Statistics palette. This VI returns the 
average of the temperature measurements. 

e. Right-click the output terminals of the Array Max & Min function and 
Mean VI and select Create»Indicator from the shortcut menu to 
create the Max, Min, and Mean indicators. 

f. Place the Write LabVIEW Measurements File Express VI located on 
the Functions»Output palette.  LabVIEW will automatically insert 
the From DDT function into the wire you connect to the Signals input. 

3. Save the VI as Temperature Logger.vi. 
4. Display the front panel and run the VI. 
5. After pressing STOP a dialog box will appear.  Enter the name of the file to 
save the spreadsheet. 
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6. Open the spreadsheet file to make sure the file was properly created by using 
Notepad or by creating a VI to read the file as follows. 



• Create the following block diagram 

 
• Place the Read LabVIEW Measurement File Express VI located on 

the Functions»Input palette. 
• Configure the VI to ask the user to choose the file to read and 

change the delimiter to Tab 
• Right click on the Signals Output and choose create graph 

indicator 
7. Run the VI 
 

VI # 5 - USING WAVEFORM GRAPHS 
 
Front Panel 

1. Open a new VI and build the following front panel using the following tips. 
 

 
 

a. Create a waveform graph indicator from the Controls»Graph Indicators 
palette. Use the position/size/select tool to move the plot legend to the 
side, and expand it to display two plots. Use the labeling tool to change the 
plot names and the properties page to choose different colors for your 
plots. 

b. Place a Stop button on the front panel. 
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c. Place two vertical pointer slides from the Controls»Numeric Controls 
palette. Use the properties page again to change the slide fill color. 



Block Diagram 
 

3. Build the following block diagram. 
 

 
 

a. Place a While Loop from Functions»Execution Control palette.  
b. Place a Wait Until Next ms Multiple from Functions»All Functions 

»Time & Dialog and create a constant with a value of 100. 
c. Place two Simulate Signal Express VIs from the Functions»Input and 

leave the Signal type as Sine for the first Simulate Signal VI and change 
the Signal Type to Square for the second VI. Wire both of the outputs into 
the waveform graph.  A Merge Signals function will automatically be 
inserted. 

d. Expand the Simulate Signal Express VIs to show another Input/Output.  
By default, error out should appear.  Change this to Frequency by clicking 
on error out and choosing Frequency. 

 
3. Save the VI as Multiplot Graph.vi. 
4. Display the front panel and run the VI. 
5. Save and close the VI. 
 

 
 
VI # 6 - ERROR CLUSTERS & HANDLING 
 
Front Panel 

1. Open a new VI and build the following front panel using the following tips. 
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a. Create a numeric control and change the Label to Square Root Input.  

Create a numeric indicator for Square Root. 
b. Place Error In 3D.ctl from Controls»All Controls»Arrays & 

Clusters. 
c. Place Error Out 3D.ctl from Controls» All Controls»Arrays & 

Clusters. 
 
Block Diagram 
 

2. Build the following block diagram. 
 

 
 
a. Place a Case Structure from Functions»Execution Control palette.  
b. Place a Greater or Equal to 0? from the Functions»Arithmetic and 

Comparison»Comparison palette and wire it to the condition 
terminal of the case structure. 

 
In the True Case: 

c. Place the Square Root function from Functions»Arithmetic and 
Comparison»Numeric palette. 

 
In the False Case: 
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d. Create a numeric constant from Functions»Arithmetic and 

Comparison»Numeric palette and type -9999.90. 
e. Place the Bundle By Name from Functions»All Functions»Arrays & 

Clusters palette. Wire from Error in to the center terminal of Bundle 
by Name to make status show up.  Create constants.  Wire from the 
Error Out indicator to the output of Bundle By name. 

 
3. Save the VI as Square Root.vi. 
4. Display the front panel and run the VI. 
5. Save and close the VI. 
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EXPERIMENT # 4: DATA ACQUISITION 
 
 
OBJECTIVE: 
 
The objective of this experiment is acquiring data using NI USB-6009, data acquisition 
device. 
 
INTRODUCTION: 
 
The NI USB-6009 multifunction I/O is a device that can be used to connect LabVIEW to 
external devices for Data Acquisition. The NI USB-6009 is a USB based data acquisition 
(DAQ) and control device with analog input and output and digital input and output.  
 
The main features of NI USB-6009 are as follows: 
 

• Analog input (AI): 8 inputs with referenced single ended signal coupling or 4 
inputs with differential signal coupling. Software-configurable voltage ranges: 
±20V, ±10V, ±5V, ±4V, ±2.5V, ±2V, ±1.25V, ±1V. Max sampling rate is 48kS/s 
(48000 samples per second). 14 bits AD converter (USB-6008: 12 bits).  

• Analog output (AO): 2 outputs. Voltage range is 0 - 5V (fixed). Output rate is 
150Hz (samples/second). 12 bits DA converter.  

• Digital input (DI) and digital output (DO): 12 channels which can be used as 
either DI or DO (configured individually). These 12 channels are organized in 
ports, with Port 0 having lines 0, .., 7, and Port 1 having lines 0, .., 3. Input low is 
between -0.3V and +0.8V. Input high is between 2.0V and +5.8V. Output low is 
below 0.8V. Output high is above 2V (with open-drain and push-pull as options).  

• Counter: 32 bits: Counting on falling edge.  
• On-board voltage sources (available at individual terminals): 2.5V and 5.0V  
• Power: USB-6009 is powered via the USB cable.  
• Configuring and testing: USB-6009 can be configured and tested using MAX 

(Measurement and Automation Explorer) 4.0, which is installed with NI-DAQ 
8.0.  

• Application software: LabVIEW, C, or Visual Studio. 
• Platforms: Windows, Mac, Linux.  

 

INSTALLING THE DAQ 
After inserting the CD, the NI-DAQmx 7.x installer should open automatically. If not, 
select Start»Run. Enter x:\setup.exe, where x is the letter of the CD drive. Complete the 
instructions in the installer, including rebooting the computer if necessary. For 
troubleshooting instructions, refer to the Hardware Installation/Configuration 
Troubleshooter at ni.com/support/install. 

 24

 



Note: Install your driver software before installing new hardware devices, so Windows 
can detect your device. 
 
After installing the software, the actual device should be installed. This is done quite 
easily by simply plugging in the USB cable into PC and device, and then click Next on 
any dialog that appears. Next click Finish. 
 
Note USB-6008/6009 only—If this is the first time that a USB-6008/6009 device is 
installed on your computer, you might be prompted to install a USB-6xxx Firmware 
Loader. Please complete the Windows Hardware Wizard prompts to completely install 
this device. 
 
DEVICE CONFIRMATION 
 
Complete the following steps: 
1. Double-click the Measurement & Automation icon on the desktop to open MAX. 
2. Expand Devices and Interfaces, then expand NI-DAQmx Devices. 
 
  

 

 

 

 

 

 

 

 
 
 
 
 
 
 
3. Check that your device appears under Devices and Interfaces. If your device does not 
appear, press <F5> to refresh the view in MAX. If the device is still not recognized, refer 
to ni.com/support/install for troubleshooting information. 
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4. Right-click your device and select Self-Test. 
 
If you need help during the self-test, select Help»HelpTopics»NI-DAQmx and click 
Max Help for NI-DAQmx. When the self-test finishes, a message indicates successful 
verification or if an error occurred. 
 
You can also use a test panel for testing specific device functionality, such as the ability 
to acquire and generate signals. It can be done as follows: 
1. In MAX, expand Devices and Interfaces»NI-DAQmx Devices. 
2. Right-click the device to test. 
3. Select Test Panels to open a test panel for the selected device. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
4. Click Start to test different functions of the device. Click Help for instructions on 
operating the test panels. 
5. The test panel displays a message indicating whether an error occurred.  
 
 
To see the terminals of the USB-6009, select Device Pinouts in the menu shown below. 
The terminals or pins are shown in the NI-DAQmx Device Terminals window. The DAQ 
is now ready to connect external devices to LabVIEW.  
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EXERCISE 1: 
 
Reading a analog signal from a signal generator and 
displaying in Labview. 
 
The purpose of this exercise is to teach you how to build 
a LabVIEW application to retrieve voltage input values 
using the NI USB-6009 data acquisition device. 
 
1. Click “New VI” button to create a new blank 
LabVIEW program 
2. Select Front Panel and enable Controls Palette to 
choose a “Waveform Chart” indicator in “Graph” group, 
add to front panel and name it “Voltage”. 
3. Switch to Block Diagram to verify that a new data 
terminal was created (named “Voltage”). 
4. In the Block diagram, open the Functions Palette to 
get the DAQ Assistant. The path goes as 
Functions>>Express>>Input>> 
DAQ Assistant.  
Note: If you have any trouble in finding a  
block use the Search function available just below the 
Title Bar of the Functions Palette. 
5. When the DAQ Assistant is placed in the Block 
diagram window, a window with “Create New…” in the 
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title bar appears. Select Analog Input and then Voltage. 
 
6. The Physical Tab will appear showing the  
devices attached and the corresponding pins.  
Select the required pin and click Finish. 
7. Another DAQ Assistant window will appear.  
Under the Voltage Input setup, Settings Tab  
select the appropriate maximum & minimum 
input signal range and units.  
(preferably, -5 to 5 volts). Also, in the Task  
Timing Tab under Acquisition mode select 1  
Sample (On Demand).Click OK. 
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8. Connect the data output from the DAQ Assistant to the Waveform chart terminal, 
using the wiring tool. If the wiring tool does not appear automatically on moving the 
cursor over the Data output of DAQ, go to View>>Tools Palette and select the wiring 
tool.  To make wiring easier, you can invoke the Help window to support it. The Help 
window shows input and output parameters of each selected VI. (The way to display the 
Help window is to click on the Help menu selection and select the “Show Context Help” 
option)  
9. You can change the window to the Front Panel window and click the “Run” (or “Run 
Continuously”) button to execute the VI. 
10. If your waveform chart does not show the whole graph, you can change the scale of 
the Yaxis. To change the Y axis scale on the waveform chart, move the cursor to the 
graphic origin, click the left mouse button, and type in the desired value 
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11. The “Run Continuously” button executes the VI continuously. You can also add a 
“While Loop” to enhance your program. First, move mouse to the Block Diagram. Open 
the Functions Palette and select the Structures group and then the While Loop. Add the 
While Loop to the Block Diagram and enlarge it to include the DAQ Assistant and the 
Voltage Waveform data terminal. On the front panel add a Stop button (from 



Controls>>Boolean>>Stop Button) to control the execution of the While Loop. In the 
block diagram, wire the stop button of the front panel to the stop button of the while loop. 
12. After wiring, switch to Front Panel and press the RUN button to execute the VI. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
EXERCISE 2: 
 
Sending an analog signal from the NI USB 6009 and displaying in a Oscilloscope. 
 
The purpose of this exercise is to teach you how to build a LabVIEW application to send 
voltage outputs values from NI USB 6009 data acquisition cards.  
 
1. Click “New VI” button to create a new blank LabVIEW program 
2. Select Front Panel and enable Controls Palette to choose a “Waveform Chart” indicator 
in “Graph” group, add to front panel and name it “Voltage”. 
3. Switch to Block Diagram to verify that a new data terminal was created (named 
“Voltage”). 
4. In the Block diagram, open the Functions Palette to get the DAQ Assistant. The path 
goes as Functions>>Express>>Input>> DAQ Assistant.  
Note: If you have any trouble in finding a block use the Search function available just 
below the Title Bar of the Functions Palette. 
5. When the DAQ Assistant is placed in the Block diagram window, a window with 
“Create New…” in the title bar appears. Select Analog Output and then Voltage. 
6. The Physical Tab will appear showing the devices attached and the corresponding pins. 
Select the required pin and click Finish. 
7. Another DAQ Assistant window will appear. Under the Voltage Output setup, Settings 
Tab select the appropriate maximum & minimum input signal range and 
units.(preferably, 0 to 10 volts). Also, in the Task Timing Tab under Acquisition mode 
select 1 Sample (On Demand).Click OK. 
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7. Generate a sinusoidal signal using the express VI using the “Simulate sig” express VI. 
The path to access these “Functions” >> Express>> “Inputs” >> “Simulate sig”. 



Select a type of signal, its amplitude and frequency. Select a number of “samples per 
second” as 1000 and uncheck the automatic for number of samples and select “1” as 
number of samples. Now connect the output of “Simulate sig” to the voltage input of the 
DAQ Assistant. 
8. Also connect the Voltage waveform to the output of “Simulate sig”. 
9. Complete your wiring and run to see the result in your graph as well as the 
oscilloscope. 
10. The “Run Continuously” button executes the VI continuously. You can also add a 
“While Loop” to enhance your program. First, move mouse to the Block Diagram. Open 
the Functions Palette and select the Structures group and then the While Loop. Add the 
While Loop to the Block Diagram and enlarge it to include the DAQ Assistant and the 
Voltage Waveform data terminal. On the front panel add a Stop button (from 
Controls>>Boolean>>Stop Button) to control the execution of the While Loop. In the 
block diagram, wire the stop button of the front panel to the stop button of the while loop. 
12. After wiring, switch to Front Panel and press the RUN button to execute the VI. 
 
Make sure that all your external wiring is connected properly and all 
devices have a common ground. 
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EXPERIMENT # 5: SENDING AN ANALOG OUTPUT 
 
 
OBJECTIVE: 
 
The objective of this experiment is to send an analog signal from NI USB-6009 and 
displaying in the oscilloscope. 
 
INTRODUCTION: 
 
An analog or analogue signal is any variable signal continuous in both time and 
amplitude. It differs from a digital signal in that small fluctuations in the signal are 
meaningful. Analog is usually thought of in an electrical context, however mechanical, 
pneumatic, hydraulic, and other systems may also convey analog signals. 
An analog signal uses some property of the medium to convey the signal's information. 
For example, an aneroid barometer uses rotary position as the signal to convey pressure 
information. Electrically, the property most commonly used is voltage followed closely 
by frequency, current, and charge. Any information may be conveyed by an analog 
signal, often such a signal is a measured response to changes in physical phenomena, 
such as sound, light, temperature, position, or pressure, and is achieved using a 
transducer. For example, in an analog sound recording, the variation in pressure of a 
sound striking a microphone creates a corresponding variation in the voltage, amplitude 
of a current passing through it. An increase in the volume of the sound causes the 
fluctuation of the current's voltage amplitude to increase while keeping the same rhythm. 
 
EXERCISE: 
 
SENDING AN ANALOG SIGNAL FROM THE NI USB 6009 AND DISPLAYING 
IN A OSCILLOSCOPE 
 
The purpose of this exercise is to teach you how to build a LabVIEW application to send 
voltage outputs values from NI USB 6009 data acquisition cards.  
 
1. Click “New VI” button to create a new blank LabVIEW program 
2. Select Front Panel and enable Controls Palette to choose a “Waveform Chart” indicator 
in “Graph” group, add to front panel and name it “Voltage”. 
3. Switch to Block Diagram to verify that a new data terminal was created (named 
“Voltage”). 
4. In the Block diagram, open the Functions Palette to get the DAQ Assistant. The path 
goes as Functions>>Express>>Input>> DAQ Assistant.  
Note: If you have any trouble in finding a block, use the Search function available just 
below the Title Bar of the Functions Palette. 
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5. When the DAQ Assistant is placed in the Block diagram window, a window with  
“Create New…” in the title bar appears. Select Analog Output and then Voltage. 
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6. The Physical Tab will appear showing the devices attached and the corresponding pins. 
Select the required pin and click Finish. 
7. Another DAQ Assistant window will appear. Under the Voltage Output setup, Settings 
Tab select the appropriate maximum & minimum input signal range and 
units.(preferably, 0 to 10 volts). Also, in the Task Timing Tab under Acquisition mode 
select 1 Sample (On Demand).Click OK. 
7. Generate a sinusoidal signal using the express VI using the “Simulate sig” express VI. 
The path to access these “Functions” >> Express>> “Inputs” >>  “Simulate sig”. 
Select a type of signal, its amplitude and frequency. Select a number of “samples per 
second” as 1000 and uncheck the automatic for number of samples and select “1” as 
number of samples. Now connect the output of “Simulate sig” to the voltage input of the 
DAQ Assistant. 
8. Also connect the Voltage waveform to the output of “Simulate sig”. 
9. Complete your wiring and run to see the result in your graph as well as the 
oscilloscope. 
10. The “Run Continuously” button executes the VI continuously. You can also add a 
“While Loop” to enhance your program. First, move mouse to the Block Diagram. Open 
the Functions Palette and select the Structures group and then the While Loop. Add the 
While Loop to the Block Diagram and enlarge it to include the DAQ Assistant and the 
Voltage Waveform data terminal. On the front panel add a Stop button (from 
Controls>>Boolean>>Stop Button) to control the execution of the While Loop. In the 
block diagram, wire the stop button of the front panel to the stop button of the while loop. 
12. After wiring, switch to Front Panel and press the RUN button to execute the VI. 
 
Make sure that all your external wiring is connected properly and all 
devices have a common ground. 
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EXPERIMENT # 6: DIGITAL INPUT / OUTPUT 
 
 
OBJECTIVE: 
 
The objective of this experiment is to send and receive digital values using NI USB 6009 
data acquisition cards. 
 
INTRODUCTION: 
 
Digital signals are digital representations of discrete-time signals, which are often derived 
from analog signals. An analog signal is a datum that changes over time—say, the 
temperature at a given location; the depth of a certain point in a pond; or the amplitude of 
the voltage at some node in a circuit—that can be represented as a mathematical function, 
with time as the free variable (abscissa) and the signal itself as the dependent variable 
(ordinate). A discrete-time signal is a sampled version of an analog signal: the value of 
the datum is noted at fixed intervals (for example, every microsecond) rather than 
continuously. 
If individual time values of the discrete-time signal, instead of being measured precisely 
(which would require an infinite number of digits), are approximated to a certain 
precision—which, therefore, only requires a specific number of digits—then the resultant 
data stream is termed a digital signal. The process of approximating the precise value 
within a fixed number of digits, or bits, is called quantization. In conceptual summary, a 
digital signal is a quantized discrete-time signal; a discrete-time signal is a sampled 
analog signal. 
In most applications, digital signals are represented as binary numbers, so their precision 
of quantization is measured in bits. Suppose, for example, that we wish to measure a 
signal to two significant decimal digits. Since seven bits, or binary digits, can record 128 
discrete values (viz., from 0 to 127), those seven bits are more than sufficient to express a 
range of one hundred values. 
 
EXERCISE: 
 
SENDING AND RECEIVING DIGITAL SIGNALS 
 
The purpose of this exercise is to teach you how to build a LabVIEW application to send 
and receive digital values from NI USB 6009 data acquisition cards.  
 
1. Click “New VI” button to create a new blank LabVIEW program 
2. Select Front Panel and enable Controls Palette to choose a “Push Button” indicator in 
“Boolean” group (you can also use a toggle or slide switch, etc. as well), add to front 
panel and name it “Status”. 
3. Switch to Block Diagram to verify that a new data terminal was created (named 
“Status”). 
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4. In the Block diagram, open the Functions Palette to get the DAQ Assistant. The path 
goes as Functions>>Express>>Input>> DAQ Assistant.  
Note: If you have any trouble in finding a block use the Search function available just 
below the Title Bar of the Functions Palette. 
5. When the DAQ Assistant is placed in the Block diagram window, a window with 
“Create New…” in the title bar appears. Select Digital I/O and then Line Output. 
6. The Physical Tab will appear showing the devices attached and the corresponding pins. 
Select the required pin(s) and click Finish. 
7. Another DAQ Assistant window will appear. Under the Task Timing Tab under 
Acquisition mode select 1 Sample (On Demand).Click OK. 
7. If you want to send more than 1 signal at a time, then first put more Boolean 
switches/buttons on the front panel. In the Block diagram, connect all the Boolean 
terminals into one using “Functions” >> Programming>> “Arrays” >> “Build 
arrays”. Extend the size of the array according to the number of signals to send. 
8. Next connect the array output to the data pin of the DAQ assistant. 
Note: Make sure that the correct pin numbers are assigned to the Boolean switches in the 
DAQ Assistant. 
9. You can also add LEDs (from Controls>>Boolean) and connect them to the switches 
in the block diagram if you want to view the result on the front panel as well. 
10. The “Run Continuously” button executes the VI continuously. You can also add a 
“While Loop” to enhance your program. First, move mouse to the Block Diagram. Open 
the Functions Palette and select the Structures group and then the While Loop. Add the 
While Loop to the Block Diagram and enlarge it to include the DAQ Assistant and the 
Voltage Waveform data terminal. On the front panel add a Stop button (from 
Controls>>Boolean>>Stop Button) to control the execution of the While Loop. In the 
block diagram, wire the stop button of the front panel to the stop button of the while loop. 
12. After wiring, switch to Front Panel and press the RUN button to execute the VI. 
13. For testing Digital input, Select Digital I/O>>Line Input in the DAQ assistant and 
instead of Boolean switches use LEDs. Also Index array can be used.  
 
 
Note: In hard wire, real LEDs and switches can be used for demonstration. Make sure 
that all your external wiring is connected properly and all devices have a common 
ground. 
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EXPERIMENT # 7: ON-OFF CONTROL 
 
 
OBJECTIVE: 
 
The objective of this experiment is to implement ON/OFF Control. 
 
INTRODUCTION: 
 
In this experiment we will implement a simple control strategy, namely On-Off Control. 
This strategy is based on a simple condition by which the maximum control signal is 
given if the output has not reached the desired set point. When the output reaches the 
desired value a zero control signal is sent to the plant.  
 
To conduct this experiment, we will have to first connect the 2-Tank system to LabVIEW 
through the NI DAQ card. The steps are as follows: 

1. Connect the sensor of the tank system (top-most pin) to any Analog Input (AI) pin 
of the DAQ card. 

2. Next connect the motor (2nd last/above ground) to an Analog Output (AO) pin. 
3. Connect the ground of the tank (bottom most) pin to a ground of the DAQ. 

Now the hard wire connections are complete and we can start building the VI. 
 
To build the VI follow the following steps: 
1. Click “New VI” button to create a new blank LabVIEW program 
2. Select Front Panel and enable Controls Palette to choose a “Waveform Chart” icon in 
the “Graph” group, add to front panel and name it “Level”. 
3. Switch to Block Diagram to verify that a new data terminal was created (named 
“Level”). 
4. In the Block diagram, go to “Functions” >> Programming>> “Structures” >> “Flat 
Sequence” and place it in the window. Next add 4 frames to it by right clicking on the 
border of the frame and selecting Add Frame After (or Before). 
5. In the first frame go to “Functions” >> Programming>> “Timing” >> “Wait Until 
Next ms Multiple” and place the icon in the frame. Then go to “Functions” >> 
Programming>> “Numeric” >> “Numeric Constant” in the frame and enter the value 
100 in it. Wire it to the timing icon. This will set the sampling time to 100ms. 
6. In the next frame, open the Functions Palette to get the DAQ Assistant. The path goes 
as Functions>>Express>>Input>> DAQ Assistant.  
Note: If you have any trouble in finding a block use the Search function available just 
below the Title Bar of the Functions Palette. 
7. When the DAQ Assistant is placed in the Block diagram window, a window with 
“Create New…” in the title bar appears. Select Analog Input and then Voltage. 
8. The Physical Tab will appear showing the devices attached and the corresponding pins. 
Select the required pin (plant sensor) and click Finish. 

 37

9. Another DAQ Assistant window will appear. Under the Voltage Input setup, Settings 
Tab select the appropriate maximum & minimum input signal range and 



units.(preferably, 0 to 10 volts). Also, in the Task Timing Tab under Acquisition mode 
select 1 Sample (On Demand).Click OK. 
10. Wire the data pin of the DAQ Assistant i.e. sensor output to the waveform chart 
(Level). 
Note: You can also add a Tank indicator on the front panel by going to Controls>> 
Modern>>Numeric>>Tank. But for this you will have to properly scale the tank in order 
to give you accurate readings. For this multiply the sensor reading by 25 and add a 
constant to it before sending it to the tank and on the front panel manually change the 
maximum tank reading to 250. (Method of scaling can be different also.)  
11. In the third frame, go to “Functions” >> Programming>> “Comparison” >> 
“Greater Or Equal?” and place the icon. Connect the top pin (x) of the icon to the 
sensor output from DAQ Assistant and connect the bottom pin (y) to a numeric constant-
from the Numeric Palette. Enter your set point as this constant. 
12. Go to “Functions” >> Programming>> “Structures” >> “Case Structure” and 
place it in the frame. Connect the Case selector i.e. the question mark on the left border of 
the Case Structure to the output of the Comparison Icon.   
13. In the True window of the Case structure place another DAQ Assistant similar to the 
first one, except that this should be an Analog Output. Send the value of 0 to the Data pin 
by using the numeric constant function. Similarly, in the false window, send a value of 5 
to the DAQ Assistant. (You can copy-paste it from the True window.)  
14. The “Run Continuously” button executes the VI continuously. You can also add a 
“While Loop” to enhance your program. First, move mouse to the Block Diagram. Open 
the Functions Palette and select the Structures group and then the While Loop. Add the 
While Loop to the Block Diagram and enlarge it to include the whole sequence. On the 
front panel add a Stop button (from Controls>>Boolean>>Stop Button) to control the 
execution of the While Loop.  
14. In the last frame place the Stop button terminal and connect it to the stop button of the 
while loop. 
15. To make sure that the motor is turned off when the program is terminated, add 
another case structure in the last frame and connect the Case Selector (question mark on 
the left border of the Case Structure) to the Stop button. In the True window of the Case 
structure place a DAQ Assistant similar to the one in the previous frame (Analog 
Output). Next, send the value of 0 to its Data pin by using the numeric constant function. 
16. In the 2-Tank system open the exit valve a little to see the proper effect of On-Off 
Control. The valve can be opened to the number 2 position or another one depending on 
the speed of the motor. 
17. After wiring, switch to Front Panel and press the RUN button to execute the VI. 
 

 38

 



 
 

 39



EXPERIMENT # 8: ON-OFF CONTROL WITH DEAD ZONE 
 
 
OBJECTIVE: 
 
The objective of this experiment is to implement ON/OFF Control with dead zone. 
 
INTRODUCTION: 
 
This experiment is similar to the previous one with the exception that instead of having 
one fixed set-point value, it will have a fixed "Range" determined by 2 values i.e. the 
Upper and Lower limits. This is done since constant switching On and Off of the motor 
can be damaging and so the frequency of switching must be reduced. 
 
Another difference in this experiment is that we will be using an "Instrumentation    
Amplifier"- the EI-1040 Dual Programmable Gain Instrumentation Amplifier. This 
is because the NI DAQ card gives a maximum voltage of 5V whereas the Tank system 
can take up to 10V. So, we will amplify the signal from the DAQ (by a factor of 10) 
before sending it to the Tank. The pin configuration of the Amplifier is as follows: 
 

 
 
* Worst case current availability - actual 
current availability may be greater 
** Current availability is 3 ma max 
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The Amplifier needs a 5V power supply and 
its gain can be set using the Gain State pins. 
Combinations of gain can be selected so that 
for example one amplifier can have a gain of 
10 and the other have a gain of 100. The 
different gains are 1, 10, 100, and 1000 and 
can be set through the following 



combinations: 
The voltage level of a 0 is typically ground and the level of a 1 is 2 volts above the digital 
ground. 
 
To conduct the experiment, we will have to first connect the 2-Tank system to LabVIEW 
through the NI DAQ card and Amplifier set up. The steps are as follows: 

4. Connect the sensor of the tank system (top-most pin) to any Analog Input (AI) pin 
of the DAQ card. 

5. Connect the +5 In and GND In pins of the Amplifier to the 5V and ground 
terminals of the Power supply. 

6. Connect the negative input of the amplifier you are using, A- In or B- In, to 
ground and connect the positive inputs, A+ In or B+ In, to an Analog Output 
(AO) pin of the DAQ. 

7. Next connect the motor (2nd last/above ground) to the Amplifier Output i.e.  
 A Out or B Out. 
8. Connect the ground of the Amplifier to the ground of the DAQ. 
9. Connect the ground of the tank (bottom most) pin to a ground of the DAQ. 

 
Note: Make sure that ALL devices are connected to a common ground. 
Now the hard wire connections are complete and we can start building the VI. 
 
To build the VI follow the following steps: 
1. Click “New VI” button to create a new blank LabVIEW program 
2. Select Front Panel and enable Controls Palette to choose a “Waveform Chart” icon in 
the “Graph” group, add to front panel and name it “Level”. 
3. Switch to Block Diagram to verify that a new data terminal was created (named 
“Level”). 
4. In the Block diagram, go to “Functions” >> Programming>> “Structures” >> “Flat 
Sequence” and place it in the window. Next add 4 frames to it by right clicking on the 
border of the frame and selecting Add Frame After (or Before). 
5. In the first frame go to “Functions” >> Programming>> “Timing” >> “Wait Until 
Next ms Multiple” and place the icon in the frame. Then go to “Functions” >> 
Programming>> “Numeric” >> “Numeric Constant” in the frame and enter the value 
100 in it. Wire it to the timing icon. This will set the sampling time to 100ms. 
6. In the next frame, open the Functions Palette to get the DAQ Assistant. The path goes 
as Functions>>Express>>Input>> DAQ Assistant.  
Note: If you have any trouble in finding a block use the Search function available just 
below the Title Bar of the Functions Palette. 
7. When the DAQ Assistant is placed in the Block diagram window, a window with 
“Create New…” in the title bar appears. Select Analog Input and then Voltage. 
8. The Physical Tab will appear showing the devices attached and the corresponding pins. 
Select the required pin (plant sensor) and click Finish. 
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9. Another DAQ Assistant window will appear. Under the Voltage Input setup, Settings 
Tab select the appropriate maximum & minimum input signal range and units 
(preferably, 0 to 10 volts). Also, in the Task Timing Tab under Acquisition mode select 1 
Sample (On Demand).Click OK. 



10. Wire the data pin of the DAQ Assistant i.e. sensor output to the waveform chart 
(Level). 
Note: You can also add a Tank indicator on the front panel by going to Controls>> 
Modern>>Numeric>>Tank. But for this you will have to properly scale the tank in order 
to give you accurate readings. For this multiply the sensor reading by 25 and add a 
constant to it before sending it to the tank and on the front panel manually change the 
maximum tank reading to 250. (Method of scaling can be different also.)  
11. In the third frame, go to “Functions” >> Programming>> “Comparison” >> 
“Greater Or Equal?” (or "Less Or Equal?") and place the icon. Connect the top pin (x) 
of the icon to the sensor output from DAQ Assistant and connect the bottom pin (y) to a 
numeric constant-from the Numeric Palette. Enter your Upper (or Lower) limit as this 
constant. 
Note: You can also place "Vertical Pointer Slides" on the Front Panel from 
Controls>>Modern>>Numeric and use them to set the Upper/Lower limits. 
12. Go to “Functions” >> Programming>> “Structures” >> “Case Structure” and 
place it in the frame. Connect the Case selector i.e. the question mark on the left border of 
the Case Structure to the output of the Comparison Icon.   
13. In the True window of the Case structure place another DAQ Assistant similar to the 
first one, except that this should be an Analog Output. Send the value of 0 to the Data pin 
by using the numeric constant function.  
14. In the false window, place another Case structure. Place the "Less Or Equal?" icon 
outside the structure and connect its output to the Case Selector (question mark). Connect 
the top pin (x) of the icon to the sensor output from DAQ Assistant and connect the 
bottom pin (y) to a numeric constant-from the Numeric Palette. Enter your Lower (or 
Upper) limit as this constant. 
Note: You can use Vertical Pointer Slides as well. 
15. In the True window of the inner structure place another similar DAQ Assistant 
(Analog Output). Send the value of 1 (it will be later amplified to 10V) to the Data pin by 
using the numeric constant function. Leave the other window blank. 
16. In the 2-Tank system open the exit valve a little to see the proper effect of On-Off 
Control. The valve can be opened to the number 2 position or another one depending on 
the speed of the motor. 
17. In the Front Panel enable Controls Palette to choose a “Push Button” indicator in 
“Boolean” group (you can also use a toggle or slide switch, etc. as well), add 2 of them 
and name them “GSA1” and “GSA2”. In the Block Diagram (3rd frame), connect all the 
Boolean terminals into one using “Functions” >> Programming>> “Arrays” >> 
“Build arrays”. Place a DAQ Assistant and select Digital I/O and then Line Output. 
Select the required pins, select 1 Sample (On Demand) and click OK. 
Finally connect the array output to the data pin of the DAQ assistant. 
Note: Make sure that the correct pin numbers are assigned to the Boolean switches in the 
DAQ Assistant. 
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18. The “Run Continuously” button executes the VI continuously. You can also add a 
“While Loop” to enhance your program. First, move mouse to the Block Diagram. Open 
the Functions Palette and select the Structures group and then the While Loop. Add the 
While Loop to the Block Diagram and enlarge it to include the whole sequence. On the 



front panel add a Stop button (from Controls>>Boolean>>Stop Button) to control the 
execution of the While Loop.  
19. In the last frame place the Stop button terminal and connect it to the stop button of the 
while loop. 
20. To make sure that the motor is turned off when the program is terminated, add 
another case structure in the last frame and connect the Case Selector (question mark on 
the left border of the Case Structure) to the Stop button. In the True window of the Case 
structure place a DAQ Assistant similar to the one in the previous frame (Analog 
Output). Next, send the value of 0 to its Data pin by using the numeric constant function. 
21. After wiring, switch to Front Panel and press the RUN button to execute the VI. 
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EXPERIMENT # 9: PROPOTIONAL CONTROL 
 
 
OBJECTIVE: 
 
The objective of this experiment is to implement Proportional Control 
 
INTRODUCTION: 
 
Proportional Controller (part of the PID controller) is a common feedback loop 
component in industrial control systems. The controller takes a measured value from a 
process or other apparatus and compares it with a reference setpoint value. The difference 
(or "error" signal) is then used to adjust some input to the process in order to bring the 
process' measured value back to its desired setpoint. Basically, when the controller reads 
a sensor, it subtracts this measurement from the "setpoint" to determine the "error". It 
then uses the error to calculate a correction to the process's input variable (the "action") 
so that this correction will remove the error from the process's output measurement.  
 

It is used mainly to handle the immediate error, which is multiplied by a constant P (for 
"proportional"), and added to the controlled quantity. P is only valid in the band over 
which a controller's output is proportional to the error of the system. This is known as the 
Propotional Band, often abbreviated as Pb. A controller setting of 100% proportional 
band means that a 100% change of the error signal (setpoint – process variable) will 
result in 100% change of the output, which is a gain of 1.0. A 20% proportional band 
indicates that 20% change in error gives a 100% output change, which is a gain of 5. 

 
        Pb = 100/gain   OR 
 
With proportional band, the controller output is proportional to the error or a change in 
measurement (depending on the controller). So,  
 
(controller output) = (error)*100/(proportional band) 
 
This theory will be implemented on the 2-Tank system in this experiment. The controller 
will be designed in a VI while the hardware connections remain the same- as shown 
below: 
 

10. Connect the sensor of the tank system (top-most pin) to any Analog Input (AI) pin 
of the DAQ card. 

11. Connect the +5 In and GND In pins of the Amplifier to the 5V and ground 
terminals of the Power supply. 
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12. Connect the negative input of the amplifier you are using, A- In or B- In, to 
ground and connect the positive inputs, A+ In or B+ In, to an Analog Output 
(AO) pin of the DAQ. 

http://en.wikipedia.org/wiki/Feedback_loop
http://en.wikipedia.org/wiki/Control_system
http://en.wikipedia.org/wiki/Industrial_process
http://en.wikipedia.org/wiki/Setpoint


13. Next connect the motor (2nd last/above ground) to the Amplifier Output i.e. A Out 
or B Out. 

14. Connect the ground of the Amplifier to the ground of the DAQ. 
15. Connect the ground of the tank (bottom most) pin to a ground of the DAQ. 

 
Note: Make sure that ALL devices are connected to a common ground. 
 
The VI will be build as follows: 
1. Click “New VI” button to create a new blank LabVIEW program. 
2. In the Block diagram, go to “Functions” >> Programming>> “Structures” >> “Flat 
Sequence” and place it in the window. Next add 4 frames to it by right clicking on the 
border of the frame and selecting Add Frame After (or Before). 
3. Keep the 1st two frames and the last frame the same as they were for On-Off Control 
viz. 

• The 1st frame to set the sampling time to 100ms- using Wait Until Next ms 
Multiple and Numeric Constant. 

• The 2nd frame to receive the sensor signal from the Tank, scale it properly and 
display it on the front panel in a graph as well as tank format- using DAQ 
Assistant, Waveform Chart, Tank and other numeric icons. 

• The last frame to manually terminate the execution of the program through a 
stop button on the front panel and make sure the motor is turned off at the 
end- using DAQ Assistant, Case Structure and Numeric Constant. 
(The entire Flat Sequence must be included in the while loop and the Stop 
button terminal must be connected to the stop button of the while loop) 

4. Calculate the Error by subtracting (“Functions” >> Programming>> “Numeric” >> 
“Subtract”) the sensor value or level from the desired set point. The set point can be 
given in the form of a Numeric Constant in the Block diagram or through Vertical pointer 
slides, Numeric controls, etc. on the Front panel. This can be done in the 2nd or 3rd frame. 
5. On the front panel, add a Control Knob from the Numeric palette. This will be used to 
control the Proportional gain Kp. In the 3rd frame of the Block diagram sequence, multiply 
the error with the gain- connect the error and gain terminal to a multiplication block. 
6. In the same frame check the above product (input to controller) and if it is greater than 
1 send one to the Tank system- using DAQ. If it is lesser than 0 send the tank 0. If it is 
between 0 and 1, send the control input as it is. The comparison can be done using 
“Greater Or Equal?” and “Lesser Or Equal?” functions along with a Case Structure 
having another Case Structure inside (as in the On-Off Control). Here the control input is 
connected to the Case Selector. 
7. After all the wiring is complete switch to Front Panel and press the RUN button to 
execute the VI. 
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EXPERIMENT # 10: PI CONTROLLER 
 
 
OBJECTIVE: 
 
The objective of this experiment is to implement PI Controller. 
 
INTRODUCTION: 
 
The next step in PID control is the inclusion of the Integral component – It is needed to 
learn from the past. The error is integrated (added up) over a period of time, and then 
multiplied by a constant Ki (making an average), and added to the controlled quantity. A 
simple proportional system either oscillates, moving back and forth around the setpoint 
because there's nothing to remove the error when it overshoots, or oscillates and/or 
stabilizes at a too low or too high value. By adding a proportion of the average error to 
the process input, the average difference between the process output and the setpoint is 
continually reduced. Therefore, eventually, a well-tuned PID loop's process output will 
settle down at the setpoint. As an example, a system that has a tendency for a lower value 
(heater in a cold environment), a simple proportional system would oscillate and/or 
stabilize at a too low value because when zero error is reached P is also zero thereby 
halting the system until it again is too low. Larger Ki implies steady state errors are 
eliminated quicker. The tradeoff is larger overshoot: any negative error integrated during 
transient response must be integrated away by positive error before we reach steady state. 
The integral component is always used with the proportional one and is so referred to as 
PI controller. 
 
This theory will be implemented on the 2-Tank system in this experiment. The controller 
will be designed in a VI while the hardware connections remain the same- as shown 
below: 
 

16. Connect the sensor of the tank system (top-most pin) to any Analog Input (AI) pin 
of the DAQ card. 

17. Connect the +5 In and GND In pins of the Amplifier to the 5V and ground 
terminals of the Power supply. 

18. Connect the negative input of the amplifier you are using, A- In or B- In, to 
ground and connect the positive inputs, A+ In or B+ In, to an Analog Output 
(AO) pin of the DAQ. 

19. Next connect the motor (2nd last/above ground) to the Amplifier Output i.e.  
 A Out or B Out. 

20. Connect the ground of the Amplifier to the ground of the DAQ. 
21. Connect the ground of the tank (bottom most) pin to a ground of the DAQ. 

 
 
Note: Make sure that ALL devices are connected to a common ground. 
The VI will be build as follows: 
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1. Click “New VI” button to create a new blank LabVIEW program. 



2. In the Block diagram, go to “Functions” >> Programming>> “Structures” >> “Flat 
Sequence” and place it in the window. Next add 4 frames to it by right clicking on the 
border of the frame and selecting Add Frame After (or Before). 
3. Keep the 1st two frames and the last frame the same as they were for On-Off Control 
viz. 

• The 1st frame to set the sampling time to 100ms- using Wait Until Next ms 
Multiple and Numeric Constant. 

• The 2nd frame to receive the sensor signal from the Tank, scale it properly and 
display it on the front panel in a graph as well as tank format- using DAQ 
Assistant, Waveform Chart, Tank and other numeric icons. 

• The last frame to manually terminate the execution of the program through a 
stop button on the front panel and make sure the motor is turned off at the 
end- using DAQ Assistant, Case Structure and Numeric Constant. 
(The entire Flat Sequence must be included in the while loop and the Stop 
button terminal must be connected to the stop button of the while loop) 

4. Calculate the Error by subtracting (“Functions” >> Programming>> “Numeric” >> 
“Subtract”) the sensor value or level from the desired set point. The set point can be 
given in the form of a Numeric Constant in the Block diagram or through Vertical pointer 
slides, Numeric controls, etc. on the Front panel. This can be done in the 2nd or 3rd frame. 
5. On the front panel, add 2 Control Knobs from the Numeric palette. This will be used to 
control the Proportional gain Kp and the Integral Gain KI.  
6. In the 3rd frame of the Block diagram sequence, check if the error is less than zero. If it 
is, then send the tank 0.If not go to the next step. The comparison can be made using the 
Case Structure and the “Lesser Or Equal?” function. 
7. Multiply the error with the gain by connecting the error and gain terminal to a 
multiplication block. Also, integrate the error by sending it to the Integral block 
(“Functions” >> Mathematics>> Integ & diff >>Time Domain Math- select Integral 
in this block) and then multiply the integrated error with the Integral gain as was done 
with the Proportional gain. Next, add the 2 products together (use compound arithmetic 
or 2 add functions). Send the sum to the Tank through the DAQ Assistant. 
8. In the same frame check the above product (input to controller) and if it is greater than 
1 send one to the Tank system- using DAQ. If it is lesser than 0 send the tank 0. If it is 
between 0 and 1, send the control input as it is. The comparison can be done using 
“Greater Or Equal?” and “Lesser Or Equal?” functions along with a Case Structure 
having another Case Structure inside (as in the On-Off Control). Here the control input is 
connected to the Case Selector. 
9. In the 2-Tank system open the exit valve a little to see the proper effect of the PI 
Control. The valve can be opened to the number 2 position or another one depending on 
the speed of the motor. 
10. After all the wiring is complete switch to Front Panel and press the RUN button to 
execute the VI. 
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