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   FIRST OPNET FROM SCRATCH 

 
OBJECTIVES: 
 
1. Continue introduce students to network simulation using OPNET. 
2. Create a simple network model. 
3. Collect statistics on network performance through the use of OPNET tools. 
4. Analyze statistics and draw conclusions on network performance. 
 
REFERENCES: 
 
1. OPNET Online Documentation. 
 
EQUIPMENT AND SOFTWARE: 
 
1. Network Laboratory 22/347-A 
1. OPNET Version 8.0 
 
INTRODUCTION: 
 
  OPNET was the first commercial networking software based on modeling and simulation 
technology developed in 1987.  There are other simulation software in the market; however, the 
OPNET is the leader in this niche market.  OPNET is located in Washington D.C.  The OPNET users 
include MIT, UI, NASA, AT&T, BOEING, Hughes, Hewlett Packard, CISCO, Qualcomm, Loral, and 
Intelsat to name a few.  There are three versions of OPNET software which are marketed by the 
company.  OPNET Modeler is one of these three and will be used for this course.  OPNET network 
simulation is becoming an industry standard and used for both military and commercial enterprises.   
The simulation tool is design for highly technical use.  However, in this course we shall use the tool as 
a rudimentary introduction tool for the WAN topics.  This course is not intended to teach all the 
complexities of simulation setup and manipulation. 
 
OBJECTIVE: 
 
  Create a simple multiple switch based Ethernet network with a switch, a server and group of 20 
clients and observe the result of the simulation run.  Note, this lab uses components of LAN.  The 
extension of the LAN will be performed in the subsequent labs to extend the LAN into WAN 
implementation.  You must keep a copy of the simulation in your U: drive (or zip drive).  The files to 
be created will result in 10’s of megabytes of data.  You cannot save the model on the floppy.  
 
Your task is to create the following model.  The node numbers need not be as shown.  You will be 
creating a 20 workstation based network which shares resource from the server (in this model it is 



node_21).  The network type if Ethernet 10 BaseT.  We will use default settings on most of the objects 
shown.  The details about the individual setting and its implication will be explored in the future labs. 
 
Make sure you capture frequent screenshots to support your lab write up.  This lab is not intended to be 
used for deep analysis of the network operation.  Your main task is to get comfortable with the 
network model set up and general operations within the OPNET. 
 

 
Figure 1.  Lab 2 model to be built 

 
PROCEDURE: 
 

1. Create a Project and Scenario:  Launch OPNET Modeler by simply using the Start button 
on the windows interface, clicking Programs → OPNET Modeler 9.0 → OPNET Modeler.  
Double-click on OPNET Modeler to launch the simulation software.  You should have the 
screen picture below (figure 2.) if you executed these steps correctly.  If not, simply close out 
the other windows and try again. 



 
Figure 2.  OPNET Modeler Main Menu 

 
2. From the File menu, choose New, and then select Project and OK 

 
3. Name your project lastname_net1 & scenario lab1, and then click next 

   
2. Build the first_floor network using Startup Wizard:  The end state is to establish a 
10baseT LAN with thirty users and one server.  This is initiated through the use of the Startup 
Wizard function.  From the main menu, select Network and then Startup Wizard.  Make the 
following entries for the next successive entries and press next. 

 
    Initial Topology:  Empty 
    Choose Network Scale: Office 
    Specify Size:   100ft X 100ft (default setting) 
    Select Grid Properties: 12.5ft (default setting) 
     

5. Select Technologies: As depicted in figure 3, using window slide bar, move down to 
Sm_Int_Model_List  and toggle to yes.  This will provide the simulation tools to model a 
small internet which is sufficient for this simple scenario.  However, future labs will require 
various selections to provide the node and link models required to model network behavior.  
Take the time to observe and note some of the other selections which are intuitive.  After 
making the technology selection, press next and confirm your selections by pressing OK in the 
Review window. 
 

 



 
Figure 3.  Technology Selection 

 
6.   Examine the project workspace:  As a result of the Startup Wizard entries, a project workspace  and 
scenario have been created as depicted in Figure 4.  The object palette is created as a result of 
technology selections and depicts real world network objects which are “clicked and dragged” into the 
workspace to construct simulations.  There are two primary types of objects; nodes and links.  Nodes 
are communication devices that can transmit and receive information.  Link objects are which represent 
the communication medium which connects the nodes together.  Figure 4 annotates a 10BaseT link 
object and a small internet server (Sm_Int_server) node object.  Figure 4 also depicts the 12.5m x 
12.5m grid which provides a visual reference for distance and within the 100m x 100m workspace 
defined by the initial Startup Wizard entries.      
 

 
Figure 4.   Project Object Pallet  

  
7.  Create the network in the workspace:  The fastest way to create a new local area network (LAN) 
network topology is by using the Rapid Configuration feature.  Close out the Object Palette window.  
Go to the main menu and select Network and then Rapid Configuration.  Specify star configuration 
and press OK for initial Rapid Configuration window.  The following selections are made in the Rapid 
Configuration: Star window as depicted in Figure 5; Center Node Model → 
3C_SSII_1100_3300_4s_ae52_e48_ge3 (3Com Router/Ethernet Hub), Periphery Node Model → 



Sm_Int_wkstn, Link Model → 10BaseT (communication medium with hub), Number = 20 (number 
of workstations), Placement Center X = 50 (ft) and Y = 50 (ft), Radius = 20 (ft).  Press OK and 
OPNET will implement the first_floor LAN configuration in workspace as depicted in Figure 1.        
  

 
Figure 5.  Rapid Configuration: Star 

 
8. Add server to the LAN network model:  Open up the Object Palette by pressing the 
paintbrush icon from the main menu.  With a single right click of your mouse, scroll down to 
Sm_Int_server (see Figure 4) and select this node object.  Slide the cursor over to the workspace near 
the Lab1 and position as shown in Figure 1 with a left click of the mouse.  Right click your mouse to 
deselect this node object.  Note:  additional left clicks of the mouse would have added additional 
servers.  Following the deselection, a second left click with the mouse is used to “degroup” all objects 
which have been added to the network model.  Unintended objects can be eliminated by using a left 
click select on the node object and pressing Cut from the main menu.  The delete button will not 
work in this situation!  To delete an object first select the object and use the key sequence 
control-x. 
 
9. Establish 10BaseT connection between LAN and Server:  Open up the Object Palette by 
pressing the paintbrush icon from the main menu.  With a single right click of your mouse, scroll 
down to 10BaseT (see Figure 4) and select this node object.  Position the cursor over the 3Com hub 
and left click.  Slide the cursor over to the server object and left click.  If done correctly, a 10BaseT 
link will exist between the server and the 3Com hub as depicted in Figure 1.   
 
10. Specify application traffic that will exist on the network:  Using the object palette, place the 
Sm_Application_Config object in the palette and drag into the workspace as shown in Figure 1.  
Right Click to turn off object creation.  Also place the Sm_Profile_Config object into the workspace 
as shown in Figure 1.  The purpose of both of these objects is to model to application traffic for this 
scenario.  For the purposes of this scenario, each default user profile will attempt Data Access (Light) 
with the single server to measure performance.   
 
11. Close out object palette and save project file:  Close out the object palette window since the 
Lab 2 LAN is complete.  Select File → Save to save your project file.   



 
Select statistics for collection:  In OPNET, as in C++, there are statistics with varying scope.  In 
general there are two types; global statistics for the entire network and object statistics which can be 
collected from each individual node and link.  Let’s set network data to be recorded during the 
simulation.  There is no default report selected.  You must select the report to be collected.   
 
 a.  Selecting the individual server Ethernet Load Statistic:  Place your pointer over the server 
in the workspace and right click.  As shown in Figure 6, select Choose Individual Statistics from the 
servers object pop-up menu.  The Choose Results Dialog Box hierarchically organizes the statistics 
you may collect.  To collect the Ethernet Load on the server, expand the Ethernet Branch and select 
Load (bits/sec) to activate collection for this statistic.  Click OK to dismiss the dialog box.          
This statistic is the throughput in bits transmitted per second transmitted by the server.  In effect we are 
simulating the effective throughput required to support 20 workstations connected through 10baseT 
using a switch. 

 
Figure 6.  Server Individual Statistic Selection 

 b. Selecting Global Ethernet Delay:  Global statistics are used to collect information on the 
network as a whole.  For example, you can find out the delay for the entire network by collecting the 
Global Delay statistic.  Right Click in the project workspace and select Choose Individual Statistics (or 
access via File Menu: Simulation → Choose Individual Statistics).  Again, the Choose Results 
dialog box hierarchically organizes the statistics you may collect.  Under Node Statistics, expand the 
Ethernet branch and select Delay (sec) to turn on  collection.  Click OK to dismiss the dialog box, 
Choose Save from the File Menu to save your project scenario!   
 



12. Input Configure Simulation parameters:  Now that the network has been designed and the 
statistics for collection have been specified, you can execute the OPNET simulation.  Choose 
Configure Simulation from the Main Menu; Simulation → Configure Simulation.  As shown in 
Figure 7, enter or verify (most default settings) the following parameters in the Configure Simulation 
dialog box; Duration = 0.5 hours, Values Per Statistic = 100, and Seed = last four of SSN.  Once you 
have finished, close the Configure Simulation dialog box and save your project workspace.  This 
extra step will lock in the changes to the simulation parameters.  Re-open the Configure Simulation 
window and press Run to execute the simulation.   An Simulation Sequence window will appear on 
the screen and notify you when the simulation has been completed.  Press Close when simulation has 
completed or notify instructor if program aborts due to errors.  
 

 
Figure 7.  Configure Simulation Parameters 

 
13. Select View Results of server Ethernet Load:  To view the statistics you have collected, you 
can either use the object or workspace pop-up menu.  To view the server Ethernet Load for the 
simulation, right click on the server node and choose View Results from the servers object pop-up 
menu.  Expand the Ethernet branch and select Load (bits/sec).  Click Show to view results.  You can 
capture your results and copy to Microsoft Word by pressing ctrl-alt-print scrn and pasting into 
PowerPoint slide.  Then copy the PowerPoint slide into a word document to publish results.  By 
placing your cursor over the maximum point and pressing the left click button, a dialog box will appear 
with the X and Y coordinates to record accurate measurement vice visual   readings.  The graph you 
simulation result will vary. 



 
Figure 8. 

• Record the peak Load (bits/sec)___________________________________. 
 
15.   Select View Results of global Ethernet Delay:  To view the global Ethernet Delay from the 
simulation, right-click in the project workspace and choose View Results from the pop-up menu.  
Expand the Ethernet branch and select Delay (sec).  Click Show to view the results.  Use Microsoft 
Word to capture the lab results and record the maximum value below using the method explain in Step 
14. 
 
• Record the peak Ethernet Delay(sec)________________________________.  
 
 
SUBMISSION REQUIREMENTS: 
 
1. Publish a Word Document which includes the following information: 
 

a.   Graph of Server Load (bits/sec)  
b.  Graph of Global Ethernet Delay (sec)  
c.   Server Load (bits/sec) Peak Value  
d.  Global Ethernet Delay (sec) Peak Value for first_floor scenario 
e.   Screenshot of the model. 

 
 
Note: we shall build the lab #3 upon this lab.  Please make sure that your simulation runs properly.    
    

 
 
  


