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RSVP: Resource Reservation Protocol  
Providing QoS by Reserving Resources in the Network 

Objective 

The objective of this lab is to study the Resource Reservation Protocol (RSVP) as a part of 
the Integrated Services approach to providing Quality of Service (QoS) to individual 
applications or flows. 

Overview 

For many years, packet-switched networks have offered the promise of supporting 
multimedia applications, that is, those that combine audio, video, and data. Audio and 
video applications are examples of real-time applications. The best-effort model, in which 
the network tries to deliver your data but makes no promises and leaves the “cleanup 
operation” to the edges, is not sufficient for real-time applications. What we need is a new 
service model—one in which applications that need better assurances can request such 
service from the network. The network may then respond by providing an assurance that it 
will do better, or perhaps by saying that it cannot promise anything better at the moment. A 
network that can provide different levels of service is often said to support QoS. 
 
Two approaches have been developed to provide a range of QoS: Integrated Services 
and Differentiated Services. The Resource Reservation Protocol follows the Integrated 
Services approach, whereby QoS is provided to individual applications or flows. The 
Differentiated Services approach provides QoS to large classes of data or aggregated 
traffic. 
 
While connection-oriented networks have always needed some sort of setup protocol to 
establish the necessary virtual circuit state in the routers, connectionless networks like the 
Internet have had no such protocols. One of the key assumptions underlying RSVP is that 
it should not detract from the robustness that we find in the Internet. Therefore, RSVP 
uses the idea of soft state in the routers. Soft state—in contrast to the hard state found in 
connection-oriented networks—does not need to be explicitly deleted when it is no longer 
needed. Instead, it times out after some fairly short period if it is not periodically refreshed. 
RSVP adopts the receiver-oriented approach—the receivers keep track of their own 
resource requirements, and they periodically send refresh messages to keep the soft state 
in place. 
 
In this lab you will set up a network that carries real-time applications and that utilizes 
RSVP to provide QoS to one of these applications. You will study how RSVP contributes 
to the performance of the application that makes use of it. 
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Procedure 

Create a New Project 

1. Start OPNET IT Guru Academic Edition ⇒ Choose New from the File menu. 

2. Select the project you created in Lab 9: <your initials>_Queues ⇒ Click OK. 

3. From the File menu, choose Save As ⇒ Rename the project to  
<your initials>_RSVP ⇒ Click OK. 

4. From the Scenarios menu, choose Manage Scenarios ⇒ Click on FIFO ⇒ 
Click Delete ⇒ Click on PQ ⇒ Click Delete. 

 

 

 

 

 

 

5. Click on WFQ and rename it to QoS_RSVP ⇒ Click OK. 

6. Make sure that you have only one scenario in your project named QoS_RSVP. 
The following figure shows one way to check for the available scenarios in the 
project. 

 

 

 

 

 

 

 

 

7. Save your project. 

The idea of the FQ (fair 
queuing) discipline is to 
maintain a separate 
queue for each flow 
currently being handled 
by the router. The router 
then services these 
queues in a round-robin 
manner. WFQ allows a 
weight to be assigned to 
each flow (queue). This 
weight effectively 
controls the percentage 
of the link’s bandwidth 
each flow will get. We 
could use the ToS (Type 
of Service) field in the IP 
header to identify that 
weight. 
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Configure the Network 

Add More VoIP Nodes: 

In this project we will set up the two VoIP nodes so that one will always be the Caller party 
and the other will be the Called party. In addition, we will add two new VoIP Caller and 
Called nodes. These new nodes will utilize RSVP to reserve their required resources 
through the network. 

1. Right-click on the VoIP East node ⇒ Edit Attributes ⇒ Rename the node to 
Voice Called ⇒ Assign None to the Application: Supported Profiles attribute 
⇒ Assign Voice Called to the Client Address attribute ⇒ Click OK. 

2. Right-click on the VoIP West node ⇒ Edit Attributes. 

i. Rename the node to Voice Caller. 

ii. Assign None to the Application: Supported Services attribute. 

iii. Edit the value of the Application: Destination Preferences attribute ⇒ Set 
Rows to 1 ⇒ Assign Voice Destination to the Symbolic Name of the new 
row ⇒ Edit the Actual Name attribute ⇒ Set Rows to 1 ⇒ Assign Voice 
Called to the Name attribute of the new row as shown. 

iv. Click OK three times. 
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3. Click on the Voice Called node to select it ⇒ From the Edit menu, select Copy 
⇒ From the Edit menu, select Paste (alternatively, use the standard keyboard 
shortcuts, Ctrl-C and Ctrl-V). 

i. Locate the new node somewhere below the Voice Called node on the screen 
⇒ Connect the new node to the East Router using a 10BaseT link. 

ii. Right-click on the new node ⇒ Edit Attributes. 
iii. Click on the ethernet_wkstn value of the model attribute ⇒ Select Edit ⇒ 

Select the ethernet_wkstn_adv model. 
iv. Rename it to Voice_RSVP Called ⇒ Assign Voice_RSVP Called to its 

Client Address attribute. 
v. Click OK. 

4. Copy and paste the Voice Caller node.  

i. Locate the new node somewhere below the Voice Caller node ⇒ Connect 
the new node to the West Router using a 10BaseT link. 

ii. Right-click on the new node ⇒ Edit Attributes.  
iii. Click on the ethernet_wkstn value of the model attribute ⇒ Select Edit ⇒ 

Select the ethernet_wkstn_adv model. 
iv. Rename it to Voice_RSVP Caller.  
v. Edit the Application: Destination Preferences attribute ⇒ Open the Actual 

Name table by clicking in the value field of Actual Name ⇒ Assign 
Voice_RSVP Called to the Name attribute. 

vi. Click OK three times. 

5. Rename the Queues node in the project to QoS. Your project should look like the 
following diagram. 

6. Save your project. 
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Define the Data Flow: 

Here, we will define the data flow characteristics of the voice traffic in the network. The 
sender’s RSVP module periodically sends RSVP Path messages that uses the data flow 
characteristics to describe the traffic generated by the sender.  When the receiver’s RSVP 
module receives the Path message, the receiver host application checks the 
characteristics of the requested data flow and decides if resources should be reserved. 
Once a decision is made to request network resource reservation, the host application 
sends a request to the local RSVP module to assist in the reservation setup. The 
receiver’s RSVP module then carries the request as Resv messages to all nodes along 
the reverse data path to the sender. 

The flow is defined by its required bandwidth and buffer size. Bandwidth is set to be the 
token bucket rate in the flow specification of the Path and Resv messages. The buffer size 
represents the amount of the application “bursty” data to be buffered. It specifies the token 
bucket size that will be set in the Path or Resv messages for the session. 

1. Right-click on the QoS node ⇒ Edit Attributes. 

i. Expand the RSVP Flow Specification hierarchy and its row 0 hierarchy ⇒ 
Set Name to RSVP_Flow ⇒ Assign 50,000 to the Bandwidth (bytes/sec) 
attribute ⇒ Assign 10,000 to the Buffer Size (bytes) attribute. 

ii. Expand the RSVP Profiles hierarchy and its row 0 hierarchy ⇒ Set Profile 
Name to RSVP_Profile. 

iii. Click OK and then save your project. 
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Configure the Application: 

Here we will create a VoIP application that utilizes the RSVP flow specifications we 
configured. 

1. Right-click on the Applications node ⇒ Edit Attributes ⇒ Expand the 
Applications Definitions hierarchy ⇒ Set rows to 4 (to add a fourth row to the 
Application Definitions attribute). 
i. Name and set the attributes of row 3 as shown: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

ii. Click on the PCM Quality Speech value (shown above) ⇒ Select Edit ⇒ 
Edit the value of the RSVP Parameters attribute ⇒ Assign the following 
values (recall that we defined the RSVP_Flow in the QoS node) ⇒ Click OK 
three times. 
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Note that the characteristics of the Outbound Flow are carried in the Path messages to 
be sent from sender to receiver, and the characteristics of the Inbound Flow parameters 
are carried in the Resv messages to be sent from the receiver to the sender. 

 

Configure the Profile: 

1. Right-click on the Profiles node ⇒ Edit Attributes ⇒ Expand the Profile 
Configuration hierarchy ⇒ Set rows to 4 (to add a fourth row to the Profile 
Configuration attribute) ⇒ Name and set the attributes of row 3 as shown: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2. Click OK and then save your project. 

 



 

 8

Configure the Interfaces: 

OPNET IT Guru supports RSVP on a per-interface basis; RSVP can be enabled or 
disabled for each node’s interface. 

1. Simultaneously select (shift + left-click) the following three links: 

 

 

 

 

 

 

 

 

 

2. From the Protocols menu, select RSVP ⇒ Select Configure Interface Status 
⇒ Make the selections shown below in the configuration dialog box ⇒ Click OK 
and then save your project. 

 

 

 

 

 

 

 

 

 

The above process enables RSVP on all interfaces along the path between the two Voice 
parties that need to utilize RSVP. 
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Configure the Hosts and Routers: 

In OPNET IT Guru, the RSVP process runs only in IP-enabled nodes. The advanced 
versions (*_adv) of those node models must be used, as we did already, to configure 
RSVP-related parameters. In addition, the RSVP model in OPNET IT Guru requires either 
WFQ or custom queuing schemes. 

1. Right-click on the Voice_RSVP Caller node ⇒ Edit Attributes. 

i. Expand the Application: Supported Profiles hierarchy and its row 0 
hierarchy ⇒ Assign VoIP_RSVP Profile to the Profile Name attribute. 

ii. Expand the Application: RSVP Parameters hierarchy ⇒ Expand its Voice 
hierarchy ⇒ Enable the RSVP Status ⇒ Expand the Profile List hierarchy 
⇒ Assign to the Profile attribute of row 0 the value RSVP_Profile. 

 

 

 

 

 

 

iii. Expand the IP Host Parameters hierarchy ⇒ Expand its Interface 
Information hierarchy ⇒ Expand the QoS Information hierarchy ⇒ Assign 
WFQ to the Queuing Scheme attribute ⇒ Assign ToS Based to the 
Queuing Profile attribute ⇒ Assign RSVP Enabled to the RSVP Info 
attribute. 

 

 

 

 

 

 

 

 

 

 

Type of Service (ToS) 
is assigned to the IP 
packets. It represents a 
session attribute that 
allows packets to be 
provided the appropriate 
service in the IP queues. 
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iv. Expand the RSVP Protocol Parameters hierarchy ⇒ Expand the Interface 
Information hierarchy. (You should notice that the word Enabled is listed in 
the summary line.  When you expand it, you will see that it is the value of 
RSVP Status. If Enabled is not listed, go back to the Configure the Interfaces 
steps.) ⇒ Expand the hierarchy of the row of that interface ⇒ Assign 75% to 
both the Maximum Reservable BW and Maximum Bandwidth Per Flow 
attributes as shown: 

 

 

 

 

 

 

v. Click OK. 

 

2. Right-click on the Voice_RSVP Called node ⇒ Edit Attributes. 

i. Edit the Application: Supported Services attribute. The Application: 
Supported Services Table will popup ⇒ In that table, replace the VoIP 
Application with VoIP_RSVP and click OK. 

ii. Expand the Application: RSVP Parameters hierarchy ⇒ Expand its Voice 
hierarchy ⇒ Enable the RSVP Status ⇒ Expand the Profile List hierarchy 
⇒ Edit the value of the Profile attribute of row 0 and write down 
RSVP_Profile. 

iii. Expand the IP Host Parameters hierarchy ⇒ Expand its Interface 
Information hierarchy ⇒ Expand the QoS Information hierarchy ⇒ Assign 
WFQ to the Queuing Scheme attribute ⇒ Assign ToS Based to the 
Queuing Profile attribute ⇒ Assign RSVP Enabled to the RSVP Info 
attribute. 

iv. Expand the RSVP Protocol Parameters hierarchy ⇒ Expand the Interface 
Information hierarchy. (You should notice that the RSVP Status of the 
interface that is connected to the router is Enabled. If not, go back to the 
Configure the Interfaces steps.) ⇒ Expand the hierarchy of the row of that 
interface ⇒ Assign 75% to both Maximum Reservable BW and Maximum 
Bandwidth Per Flow attributes. 

v. Click OK. 

3. Right-click on the East Router node ⇒ Edit Attributes. 

Maximum Reservable 
BW specifies the 
percentage of the 
bandwidth of the 
connected link that 
RSVP can reserve on the 
interface. 
 
Maximum Bandwidth 
Per Flow specifies the 
amount of reservable 
bandwidth that can be 
allocated to a single flow. 
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i. Click on the Ethernet4_slip8_gtwy value of the model attribute ⇒ Select 
Edit ⇒ Select the Ethernet4_slip8_gtwy_adv model. 

ii. Expand the RSVP Protocol Parameters hierarchy ⇒ Expand the Interface 
Information hierarchy. (You should notice that the RSVP Status of two 
interfaces, which are connected to the West Router and the Voice_RSVP 
Called node, are Enabled. If not, go back to the Configure the Interfaces 
steps.) ⇒ Expand the hierarchies of the rows of these two interfaces ⇒ 
Assign 75% to both Maximum Reservable BW and Maximum Bandwidth 
Per Flow attributes. 

iii. Expand the IP Routing Parameters hierarchy ⇒ Expand the Interface 
Information hierarchy ⇒ Expand the hierarchies of the rows of the same two 
interfaces you configured in the previous step (step ii) ⇒ Expand the QoS 
Information hierarchy for both ⇒ Set Queuing Scheme to WFQ and 
Queuing Profile to ToS Based for both. 

iv. Click OK. 

 

4. Right-click on the West Router node ⇒ Edit Attributes. 

i. Click on the Ethernet4_slip8_gtwy value of the model attribute ⇒ Select 
Edit ⇒ Select the Ethernet4_slip8_gtwy_adv model. 

ii. Expand the RSVP Protocol Parameters hierarchy ⇒ Expand the Interface 
Information hierarchy. (You should notice that the RSVP Status of two 
interfaces, which are connected to the East Router and the Voice_RSVP 
Caller node, are Enabled. If not, go back to the Configure the Interfaces 
steps.) ⇒ Expand the hierarchies of the rows of these two interfaces ⇒ 
Assign 75% to both Maximum Reservable BW and Maximum Bandwidth 
Per Flow attributes. 

iii. Expand the IP Routing Parameters hierarchy ⇒ Expand the Interface 
Information hierarchy ⇒ Expand the hierarchies of the rows of the same two 
interfaces you configured in the previous step (step ii)⇒ Expand the QoS 
Information hierarchy for both ⇒ Set Queuing Scheme to WFQ and 
Queuing Profile to ToS Based for both. 

iv. Click OK. 
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Choose the Statistics 

We will select statistics from three different nodes: 

Voice_RSVP Caller Statistics: 

1. Right-click on the Voice_ RSVP Caller node and select Choose Individual 
Statistics from the pop-up menu. 

2. Expand the RSVP hierarchy and select Number of Path States. 

3. Right-click on the Number of Path States statistic ⇒ Select Change Draw Style 
from the pop-up menu ⇒ Choose bar chart. 

4. Right-click on the Number of Path States statistic ⇒ Select Change Collection 
Mode from the pop-up menu ⇒ Check the Advanced checkbox ⇒ From the 
Capture mode drop-down menu, select all values, as shown⇒ Click OK. 

 

 

 

 

 

 

 

 

 

5. Expand the Voice Calling Party hierarchy and select the following statistics: 
Packet Delay Variation and Packet End-to-End Delay (sec). 

6. Click OK. 

 

Voice_RSVP Called Statistics: 

1. Right-click on the Voice_ RSVP Called node and select Choose Individual 
Statistics from the pop-up menu. 

2. Expand the RSVP hierarchy and select Number of Resv States. 

3. Right-click on the Number of Resv States statistic ⇒ Select Change Draw 
Style from the pop-up menu ⇒ Choose bar chart. 

Packet Delay 
Variation is the variance 
among end-to-end 
delays for voice packets 
received by this node.  
 
Packet End-to-End 
Delay for a voice packet 
is measured from the 
time it is created to the 
time it is received. 
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4. Right-click on the Number of Resv States statistic ⇒ Select Change Collection 
Mode from the pop-up menu ⇒ Check the Advanced checkbox ⇒ From the 
Capture mode drop-down menu, select all values ⇒ Click OK. 

5. Click OK. 

 

Voice Caller Statistics: 

1. Right-click on the Voice Caller node and select Choose Individual Statistics 
from the pop-up menu. 

2. Expand the Voice Calling Party hierarchy and select the following statistics: 
Packet Delay Variation and Packet End-to-End Delay (sec) 

3. Click OK. 

 

Configure the Simulation 

Here, we need to configure the duration of the simulation: 

1. Click on  and the Configure Simulation window should appear. 
2. Make sure that the duration is set to 150 seconds. 
3. Click on the Global Attributes tab and make sure that the following attribute is 

enabled: 
a. RSVP Sim Efficiency = Enabled. This decreases the simulation time 

and memory requirements by not sending refresh messages (i.e., Path 
and Resv refreshes). 

4. Click OK and then save your project. 
 

Run the Simulation 

To run the simulation: 

1. Click on  and then click the Run button. Depending on the speed of your 
processor, this may take several minutes to complete. 

2. After the simulation completes, click Close. 

3. Save your project. 
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View the Results 

To view and analyze the results: 
1. Select View Results from the Results menu. 
2. As shown in the following figure, choose the Packet End-to-End Delay for both 

the Voice Caller and Voice_RSVP Caller nodes. Choose Overlaid Statistics 
and time_average. 

 

 

 

 

 

 

 

 

 

 

3. Click Show to get the following graph. (Note: To zoom in on the graph, click and 
drag your mouse to draw a rectangle around the area of interest and release the 
mouse button.) 
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4. Similarly, you can get the following graph that compares the Packet Delay 
Variation for both the Voice Caller and Voice_RSVP Caller nodes. (Note: Make 
sure to “unselect” the statistics you chose for the previous graph.) 

 

 

 

 

 

 

 

 

 

 

 

 

5. Finally, prepare the graph that displays the number of Path and Resv states by 
selecting the following statistics. Make sure to select Stacked Statistics and As 
Is as shown. 
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6. Right-click on the resulting graph and choose Edit Panel Properties ⇒ Change 
the assigned values to the Horizontal Min and Horizontal Max fields as shown 
(your graph might require a slightly different range): 

 

 

 

 

 

 

 

 

 

 

7. Click OK. The resulting graph should resemble the one below. 
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Further Readings 

− OPNET RSVP Model Description: From the Protocols menu, select RSVP ⇒ 
Model Usage Guide. 

 

Questions 

1) Analyze the graphs we obtained in this lab. Show the effect of RSVP on the Voice 
application and explain the obtained numbers of Path and Resv states. 

2) How does the data rate of the link connecting the East and West routers affect 
the performance (e.g., Packet End-to-End Delay) of the Voice and Video 
Conference applications? To answer this question, create a new scenario as a 
duplicate of the QoS_RSVP scenario. Name the new scenario Q2_HighRate. In 
the Q2_HighRate scenario replace the current PPP_DS1 link (data rate 1.544 
Mbps) with a PPP_DS3 link (data rate 44.736 Mbps). 

 

Lab Report 

Prepare a report that follows the guidelines explained in Lab 0. The report should include 
the answers to the above questions as well as the graphs you generated from the 
simulation scenarios. Discuss the results you obtained and compare these results with 
your expectations. Mention any anomalies or unexplained behaviors. 

  


